Bug 187775 - add support for ipv6 to NetworkManager and dhcdbd
Summary: add support for ipv6 to NetworkManager and dhcdbd
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcdbd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 198358 (view as bug list)
Depends On: 186322
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-03 15:40 UTC by Jason Vas Dias
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-21 18:50:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Vas Dias 2006-04-03 15:40:19 UTC
+++ This bug was initially created as a clone of Bug #186322 +++

It would be nice for dhcdbd to support IPv6, as that would go a long way to
having support for the same in NetworkManager.  We'd like to make NetworkManager
the default in anaconda and IPv6 is a big feature for the next release, so this
would help us out a lot.

-- Additional comment from jvdias@redhat.com on 2006-03-22 16:47 EST --
Agreed, this has been on my to-do list for some time now; but NM also has to
handle IPv6 addresses and options, and request an 'ipv6_up' from dhcdbd .
Also NM must handle configuration of nameservers with IPv6 addresses - this
is already supported by the bind named d-bus support.

One point to note is that Ted Lemon of the ISC / Nominum (our upstream dhclient
source) is developing a new dhclient that fully supports both DHCPv6 and D-BUS
natively - this will be the way to go for the future, but it remains to be seen
whether this will be ready for FC-6. 

In any case, I'll get dhcdbd or its ISC replacement IPv6 ready for FC-6 .

Comment 1 David Cantrell 2007-03-21 21:24:34 UTC
*** Bug 198358 has been marked as a duplicate of this bug. ***

Comment 2 David Cantrell 2007-09-21 18:50:56 UTC
dhcdbd has been obsoleted by NetworkManager 0.7.0.


Note You need to log in before you can comment on or make changes to this bug.