Bug 198358 - Package dhcdbd lacks IPv6 support
Package dhcdbd lacks IPv6 support
Status: CLOSED DUPLICATE of bug 187775
Product: Fedora
Classification: Fedora
Component: dhcdbd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-07-11 06:15 EDT by Peter Vrabec
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-21 17:24:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2006-07-11 06:15:12 EDT
This bug was reported automaticaly in connection with IPv6 project.
Our aim is to support IPv6 in all Fedora Core packages so FC6 and RHEL5 will be ready for IPv6.
			
This package seems to lack IPv6 support as is illustrated in attached log.
	
Here follows part of scanning log (grep -r F_INET *)/up to 30 lines: 

/dhcdbd-1.15/dhcp_options.c:1149:    rq_ai.ai_family = AF_INET;
/dhcdbd-1.15/dhcp_options.c:1154:	if(  (aie->ai_family == AF_INET) 
/dhcdbd-1.15/tests/test_prospective_subscriber.c:33:		inet_ntop(AF_INET, (struct in_addr*)value, &(a[0]),16) 
/dhcdbd-1.15/tests/test_prospective_subscriber.c:47:		inet_ntop(AF_INET, (struct in_addr*)value, &(a[0]),16) 
/dhcdbd-1.15/tests/test_prospective_subscriber.c:60:		inet_ntop(AF_INET, (struct in_addr*)value, &(a[0]),16) 
/dhcdbd-1.15/tests/test_prospective_subscriber.c:75:		    inet_ntop(AF_INET, (struct in_addr*)p, &(a[0]),16) 
/dhcdbd-1.15/tests/test_prospective_subscriber.c:89:		    inet_ntop(AF_INET, (struct in_addr*)p, &(a[0]),16) 
/dhcdbd-1.15/tests/test_subscriber.c:33:		inet_ntop(AF_INET, (struct in_addr*)value, &(a[0]),16) 
/dhcdbd-1.15/tests/test_subscriber.c:47:		inet_ntop(AF_INET, (struct in_addr*)value, &(a[0]),16) 
/dhcdbd-1.15/tests/test_subscriber.c:60:		inet_ntop(AF_INET, (struct in_addr*)value, &(a[0]),16) 
/dhcdbd-1.15/tests/test_subscriber.c:75:		    inet_ntop(AF_INET, (struct in_addr*)p, &(a[0]),16) 
/dhcdbd-1.15/tests/test_subscriber.c:89:		    inet_ntop(AF_INET, (struct in_addr*)p, &(a[0]),16) 
/dhcdbd-1.15/tests/t.c:121:	       inet_ntop(AF_INET, (struct in_addr*)&(s.i1), &a1[0], 16),
/dhcdbd-1.15/tests/t.c:122:	       inet_ntop(AF_INET, (struct in_addr*)&(s.i2), &a2[0], 16),
/dhcdbd-1.15/tests/t.c:123:	       inet_ntop(AF_INET, (struct in_addr*)&(s.i3), &a3[0], 16)
/dhcdbd-1.15/tests/t.c:154:	       inet_ntop(AF_INET, (struct in_addr*)&(route.net), &a1[0], 16),
/dhcdbd-1.15/tests/t.c:156:	       inet_ntop(AF_INET, (struct in_addr*)&(route.router), &a2[0], 16),
/dhcdbd-1.15/tests/t.c:187:	printf("JO: ip:%s\n", inet_ntop(AF_INET, (struct in_addr*)&(jop->ip), &(a1[0]), 16));
/dhcdbd-1.15/tests/test_binary.c:129:					       inet_ntop(AF_INET, (struct in_addr*)ip_address, &a[0], 16)
/dhcdbd-1.15/tests/test_binary.c:161:					   inet_ntop(AF_INET, (struct in_addr*)subnet_mask, &a[0], 16)
Comment 1 Peter Vrabec 2007-03-20 08:06:11 EDT
Hi David, could you update status of this issue? Is it relevant? Does dhcpdbd 
support IPv6?
Comment 2 David Cantrell 2007-03-20 11:41:45 EDT
dhcdbd does not provide an interface for IPv6 support.  dhcdbd is used by
NetworkManager, so for NetworkManager to gain IPv6 support, dhcdbd needs it. 
However, after talking with Dan Williams, we concluded that dhcdbd isn't really
necessary and the correct direction to go is to remove it entirely.  Either way,
we have a fair bit of work on the client side (as in the IPv4 and IPv6 DHCP
clients) and the NetworkManager side.
Comment 3 David Cantrell 2007-03-21 17:24:31 EDT

*** This bug has been marked as a duplicate of 187775 ***

Note You need to log in before you can comment on or make changes to this bug.