Bug 187780 - tzdata/logwatch on fc5 older fc4
tzdata/logwatch on fc5 older fc4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tzdata (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Machata
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 12:03 EDT by Mostafa Afgani
Modified: 2015-05-04 21:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 12:53:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mostafa Afgani 2006-04-03 12:03:16 EDT
Description of problem:
Last friday I upgraded a fully updates FC4 box to FC5. The upgrade was
flawless. While looking for leftover FC4 packages, I came across:

[afgani@cpc155 ~]$ rpm -qa --qf %-30{NAME}' '%{DISTRIBUTION}'\n' | grep
"(FC-4)"$
logwatch                       Red Hat (FC-4)
tzdata                         Red Hat (FC-4)

and a few others (kernel_FC4, hal.fc4, gnome-kerberos,
system-config-mouse) which were easily removed.

Comparing version numbers:

[afgani@cpc155 ~]$ sudo yum list tzdata logwatch
Loading "installonlyn" plugin
Setting up repositories
core                                                                 [1/3]
core                      100% |=========================| 1.1 kB    00:00
updates                                                              [2/3]
updates                   100% |=========================|  951 B    00:00
extras                                                               [3/3]
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Installed Packages
logwatch.noarch                          7.2.1-1.fc4            installed
tzdata.noarch                            2006b-2.fc4            installed
Available Packages
logwatch.noarch                          7.1-8                  core
tzdata.noarch                            2006b-1                core

it seems that fc4 contains updated packages while fc5 does not. These
updates were released on March 22nd but the fc5 packages are dated March
6th. I searched the updates and testing branches of fc5 but it looks like
updates to those packages are not even in testing yet. I then looked
through the development branch and saw a 7.3 version of logwatch; but the
version of tzdata was still 2006b-1 (i.e. even older than the fc4 update)

Version-Release number of selected component (if applicable):
2006b-2.fc4

How reproducible:
always

Steps to Reproduce:
1. start with fully updated FC4
2. yum update to FC5
3. FC4 tzdata remains since it is newer
  
Actual results:
tzdata left behind from FC4 due to higher version #

Expected results:
fc5 version has higher version #

Additional info:
'logwatch' has the same problem (fc5 version lower than fc4 update)
Comment 1 Petr Machata 2006-04-06 09:03:45 EDT
tzdata 2006c just came out, so I'm pushing fresh package for both fc4 and fc5. 
I'm adding the logwatch owner (hi, Ivana!) to CCs, so that she notices the problem.
Comment 2 Ivana Varekova 2006-04-06 09:26:01 EDT
Thanks for the notice. The logwatch part of this problem is fixed now (fc5
version was upgraded - see bug 187778). 

Note You need to log in before you can comment on or make changes to this bug.