Bug 187796 - Anaconda crashes with AttributeError in image.py while installing packages
Anaconda crashes with AttributeError in image.py while installing packages
Status: CLOSED DUPLICATE of bug 186761
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 13:06 EDT by Jeff Lutgen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 15:07:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump from crash (108.54 KB, text/plain)
2006-04-03 13:06 EDT, Jeff Lutgen
no flags Details

  None (edit)
Description Jeff Lutgen 2006-04-03 13:06:10 EDT
Description of problem:
Anaconda crashes with AttributeError in image.py while installing packages

How reproducible:
(didn't try)

Actual results:
While installing, got CD reading error on CD #2 (error dialog had 'Cancel' and
'Retry' buttons).  Removed CD, replaced CD, clicked 'Retry' and anaconda
immediately crashed.  

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1253, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 245, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 951, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 146, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 217, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/backend.py", line 162, in doInstall
    backend.doInstall(intf, id, instPath)
  File "/usr/lib/anaconda/yuminstall.py", line 993, in doInstall
    self.ayum.run(self.instLog, cb, intf, id)
  File "/usr/lib/anaconda/yuminstall.py", line 451, in run
    self._run(instLog, cb, intf)
  File "/usr/lib/anaconda/yuminstall.py", line 459, in _run
    self.runTransaction(cb=cb)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 414, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/anaconda/yuminstall.py", line 131, in callback
    fn = self.method.getRPMFilename(os.path.basename(path), getcd(po), None)
  File "/usr/lib/anaconda/image.py", line 180, in getRPMFilename
    timer.stop()
AttributeError: 'NoneType' object has no attribute 'stop'

Local variables in innermost frame:
callback: None
self: <image.CdromInstallMethod instance at 0xb7bbd9ac>
mediano: 2
timer: None
filename: libgcj-4.1.0-3.i386.rpm

Expected results:
Clicking 'Retry' button should cause installer to try again to read the CD, and
perhaps to fail more gracefully if it's impossible to continue.

Additional info:
During my subsequent installation attempt, I selected a smaller set of packages
and the installation went fine.
Comment 1 Jeff Lutgen 2006-04-03 13:06:11 EDT
Created attachment 127245 [details]
anaconda dump from crash
Comment 2 Chris Lumens 2006-04-03 15:07:15 EDT

*** This bug has been marked as a duplicate of 186761 ***

Note You need to log in before you can comment on or make changes to this bug.