Bug 186761 - Unhandled exception which retrying read of a possibly corrupted package
Unhandled exception which retrying read of a possibly corrupted package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 187483 187646 187796 188397 188538 188890 200060 200062 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 01:11 EST by Eric Raymond
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 11:33:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Raymond 2006-03-26 01:11:47 EST
Description of problem:

Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 1253, in handleRenderCallback
  self.currentWindow.renderCallback()
File "/usr/lib/anaconda/progress_gui.py", line 245, in renderCallback
  self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 951, in nextClicked
  self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 146, in gotoNext
  self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 217, in moveStep
  rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/backend.py", line 162, in doinstall
  backend.doinstall(intf, id, InstPath)
File "/usr/lib/anaconda/yuminstall.py", line 993, in doinstall
  self.ayum.run(self.instLog, cb, intf, id)
File "/usr/lib/anaconda/yuminstall.py", line 451, in run
  self._run(instLog, cb, intf)
File "/usr/lib/anaconda/yuminstall.py", line 459, in _run
  self.runTransaction(cb=cb)
File "/usrt/lib/python2.4/site-packages/yum/__init__.py", line 414, in
runTransaction
  errors = self.ts.run(cb.callback, '')
File "/usr/lib/anaconda/yuminstall.py", line 131, in callback
  fn = self.method.getRPMFilename(os.path.basename(path), getcd(po), None)
File "/usr/lib/anaconda/image.py", line 180. in getRPMFilename
  timer.stop()
AttributeError: 'NoneType' object has no attribute 'stop'

Local variables in innermost frame:
callback: None
self: <image.CdromInstallMethod instance at 0xb7acb06c>
mediano: 2
timer: None
Filename: xscreensaver-extras-4.24-1.1.i386.rpm


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2006-03-31 10:59:49 EST
*** Bug 187483 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2006-04-03 15:05:11 EDT
*** Bug 187646 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2006-04-03 15:07:39 EDT
*** Bug 187796 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2006-04-10 11:32:06 EDT
*** Bug 188397 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2006-04-11 11:15:42 EDT
*** Bug 188538 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2006-04-13 09:45:07 EDT
*** Bug 188890 has been marked as a duplicate of this bug. ***
Comment 7 Andre Robatino 2006-04-13 23:06:32 EDT
  I filed bug #187615 which is similar, and was closed since the anacdump.txt
file made it look like a hardware problem.  However, it's not the RAM or CD
drive, since we tried replacing these.  And it's not the media, since the discs
were bought online and are the mass-produced type, which are relatively stable,
and pass mediacheck both before and after the failed install attempts.  And the
same machine installed FC4 successfully on the first try after multiple failed
attempts to install FC5 (each failing on the first install CD, only a fraction
of the way through).  I suspect that what's really going on is a kernel bug
causing what looks like a hardware problem.
Comment 8 Chris Lumens 2006-07-25 09:34:08 EDT
*** Bug 200060 has been marked as a duplicate of this bug. ***
Comment 9 Chris Lumens 2006-07-25 09:36:17 EDT
*** Bug 200062 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.