Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1878214 - Remove Pipeline Resources from Add Flow & Support Params
Summary: Remove Pipeline Resources from Add Flow & Support Params
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.z
Assignee: Christoph Jerolimov
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1875308
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-11 15:32 UTC by OpenShift BugZilla Robot
Modified: 2020-10-19 14:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-19 14:54:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6598 0 None closed [release-4.5] Bug 1878214: Add support for more params and create resources only if required 2020-10-21 07:06:24 UTC
Red Hat Product Errata RHBA-2020:4228 0 None None None 2020-10-19 14:54:48 UTC

Description OpenShift BugZilla Robot 2020-09-11 15:32:43 UTC
+++ This bug was initially created as a clone of Bug #1875308 +++

Description of problem:
With the change to the Pipeline templates to use workspaces, we'll no longer need Pipeline Resources as part of the add flow.

Version-Release number of selected component (if applicable):
- OpenShift Pipelines 1.1 (post TP2, 'ocp-4.5' channel)
- (or) OpenShift Pipelines 1.0 (pre TP2, 'preview' channel)

How reproducible:
Always

Steps to Reproduce:
1. Create a new namespace (so there is no cross pollution)
2. Go to the add flow and add a D/DC with a Pipeline
3. Check your Pipeline Resources CRs to see if any are created

Actual results:
- Currently today, we have two pipeline resources created, a git and image one.

Expected results:
- No resources to be created by the add flow
- Support the use of GIT_REPO, GIT_REVISION, IMAGE_NAME


Additional info:
https://docs.jboss.org/display/SRVKP/TP2+Release+Plan

Comment 1 Andrew Ballantyne 2020-09-24 15:12:27 UTC
Raising severity as this will highly block a clean flow out of the Operator's Templates.

This is also blocking the upgrade of the ocp4.5 channel to finalize the TP release from Pipelines.

Comment 8 Gajanan More 2020-10-07 08:34:39 UTC
Verified on
Build: 4.5.0-0.nightly-2020-10-06-162305
Browser: Google Chrome 85.0.4183.102
Marking this as verified

Comment 13 errata-xmlrpc 2020-10-19 14:54:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.15 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4228


Note You need to log in before you can comment on or make changes to this bug.