Bug 187844 - extension list too cumbersome (32 language packs???)
Summary: extension list too cumbersome (32 language packs???)
Status: CLOSED DUPLICATE of bug 355791
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
: 433163 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-03 20:59 UTC by Stig Hackvan
Modified: 2018-04-11 18:32 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 03:19:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
use %lang for langpacks (1.25 KB, patch)
2007-05-17 12:33 UTC, Remi Collet
no flags Details | Diff

Description Stig Hackvan 2006-04-03 20:59:14 UTC
Description of problem:

as of FC5, the firefox extensions dialog has become WAY (too?) CUMBERSOME...

32-ish language packs that cannot be removed from the list (by normal user
accounts, at least) make it significantly more difficult to manage
user-installed extensions...  it's unnecessary tedium to wade through the list
looking for them...  

a more user-friendly way of supporting all those language packs would be to
check the locale and install them as needed...

OR an alternative would be to install them all and leave them installed, but
just not clutter the extensions list with them.

OR an alternative would be to add ONE EXTENSION that manages the installatation
of other language packs as needed...


i'm sure this may seem trivial, but really it shouldn't be necessary to play
needle in a haystack games to manage a few installed extensions...

Comment 1 Wieland 2006-08-03 19:41:43 UTC
Moreover, unlike most configurable options, these language packs are reinstalled
each time the firefox package is upgraded, and a normal user needs to run
firefox as root (twice) to wade through the list and get rid of them. Installing
between several dozens of language packs ranging from Czech and Bokmal to
Chinese and Catalan is not a sane default on almost any system.

Comment 2 Graham Cole 2006-10-23 15:10:27 UTC
This also seems to be causing big problems for our users:

Firefox and Thunderbird are taking > 1 minute to start up the first time they
are started after logging in.

Deleting all the unneeded language packs makes this problem go away (i.e. only
takes around 10 seconds to launch, within reasonable expectation)

Comment 3 Doncho Gunchev 2007-02-20 13:34:38 UTC
I think ooo was in similar situation. There the language packs are in separate 
files now (openoffice.org-langpack-bg_BG-2.0.4-5.5.10). The same is true for 
KDE too - kde-i18n-Bulgarian-3.5.6-0.1.fc6. Maybe rpm needs a way 
to 'half-install' a package (subpackages)?

Comment 4 Remi Collet 2007-05-17 12:33:01 UTC
Created attachment 154908 [details]
use %lang for langpacks

At least, marking as %lang will allow user to select which one to install with
%_install_langs macro.

Here is a very simple patch proposal

Comment 5 Matěj Cepl 2007-07-18 17:32:07 UTC
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.


Comment 6 Doncho Gunchev 2007-07-19 12:29:00 UTC
In Fedora 7 all languages are in a separate tab (FF2), which makes the 
situation better (not that 99% of the users need more than 2). 
In FC6 (FF1.5) the situation has not changed a bit AFAIK.
Reassign to FC6?

Comment 7 Matěj Cepl 2007-07-19 14:10:24 UTC
I am afraid that this won't get fixed with 1.5.* -- unfortunately, we have more
than enough work to do on fixing more serious bugs. Patches are more than
welcome. I am sorry that we cannot help more.

Comment 8 Matěj Cepl 2008-04-09 16:24:04 UTC
*** Bug 433163 has been marked as a duplicate of this bug. ***

Comment 9 Rahul Sundaram 2008-04-09 16:57:24 UTC
Commment #4 has a patch attached that would still work. This is a Fedora
specific change and neither upstream nor other distros have this afaik.
Something need to merge the spec file changes. That's all. 

Comment 10 petrosyan 2008-04-13 07:17:18 UTC
this seems to be a duplicate of bug #355791

Comment 11 Christopher Aillon 2008-04-18 03:19:08 UTC
the patch from 355791 got used a bit ago.  duping there i guess.  but it's in f9

*** This bug has been marked as a duplicate of 355791 ***


Note You need to log in before you can comment on or make changes to this bug.