Bug 355791 - mark langpacks with %lang
mark langpacks with %lang
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
FF3RawhideClose
: i18n, Patch, Reopened
: 187844 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-28 08:15 EDT by Ville Skyttä
Modified: 2008-12-19 07:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 23:18:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mark langpacks with %lang (1.23 KB, patch)
2007-10-28 08:15 EDT, Ville Skyttä
no flags Details | Diff
Mark langpacks with %lang (1.26 KB, patch)
2007-12-20 12:15 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2007-10-28 08:15:34 EDT
The firefox package does not honor the system %_install_langs settings, it
installs all langpacks anyway.  Something like the attached patch would fix it.
Comment 1 Ville Skyttä 2007-10-28 08:15:34 EDT
Created attachment 240881 [details]
Mark langpacks with %lang
Comment 2 Matěj Cepl 2007-12-20 11:47:40 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays
Comment 3 Ville Skyttä 2007-12-20 12:14:20 EST
I don't see any %lang'ification in the FF3 specfile.  Updated patch (not build
tested) against current CVS attached.
Comment 4 Ville Skyttä 2007-12-20 12:15:09 EST
Created attachment 290171 [details]
Mark langpacks with %lang
Comment 5 Martin Stransky 2008-01-03 05:56:57 EST
taking the bug.
Comment 6 Jens Petersen 2008-01-07 00:26:23 EST
Personally I would prefer having subpackages for the langpacks,
that would make it easier for users to install just the langpacks
they need and then updates of firefox lighter for everyone.
Comment 7 Parag Nemade 2008-01-10 00:13:52 EST
I agree with Jens.
Comment 8 Christopher Aillon 2008-01-10 07:25:09 EST
NO.  That will make it so that languages do not work out of the box for things
other than english.  Until the day that every package in the distro splits its
langpacks into subpackages, Firefox is not going to do so either.  Don't even
use the "OO.org does it so firefox should too" argument because it's not going
to work on me.  Think "yum install firefox".
Comment 9 Caius Chance 2008-01-10 18:53:02 EST
Hi Christopher, I'd humble wondering if keeping every langpack in firefox
package has relatively controllable performance impacts? I support the splits
solely because we do concern the start up time of Firefox. Community feedback to
me about our Firefox spends longer than certain other distros. Rgds, Caio.
Comment 10 Jens Petersen 2008-01-10 22:42:18 EST
(In reply to comment #8)
> That will make it so that languages do not work out of the box for things
> other than english.

Well they can be installed per language as part of the language support
groups in yum.  For backward compatibility there could be a meta package
I suppose pulling them all in for people updating.

> Until the day that every package in the distro splits its
> langpacks into subpackages, Firefox is not going to do so either.

Well actually many (most?) packages do this already.
Comment 11 Ville Skyttä 2008-01-12 05:05:35 EST
(In reply to comment #10)
> (In reply to comment #8)
> > Until the day that every package in the distro splits its
> > langpacks into subpackages, Firefox is not going to do so either.
> 
> Well actually many (most?) packages do this already.

Hm?  I see kde, moodle, plexus, psi, koffice, openoffice.org, scim, and
tesseract doing this, but in contrast I dare to say (no numbers to back this up
though) we have *thousands* of packages shipping their translations in
/usr/share/locale and other locations in their main packages.
Comment 12 Christopher Aillon 2008-01-12 09:54:07 EST
Sigh.  Okay, this is turning into a silly discussion.  Not sure why I didn't
just say this before:

Please don't hijack bugs.  If you want different functionality from what's
reported, file a different bug.
Comment 13 Jens Petersen 2008-01-13 19:20:53 EST
Hmm, well the reason for "hijacking" the bug was it was an alternative
to what was being proposed here.
Comment 14 Jens Petersen 2008-01-13 19:54:34 EST
> in contrast I dare to say (no numbers to back this up
> though) we have *thousands* of packages shipping their translations in
> /usr/share/locale and other locations in their main packages.

I was referring to all the packages whose upstreams separate their translations
not the whole distro. :)

Anyway I see that this idea is not going to be accepted again, so I will
drop it again for now.  %lang marking will certainly be an improvement,
though I think most ordinary users don't know how to set it on their system.
(Maybe we should have some tool for that - though it should really be in the
installer i guess?)
Comment 15 Christopher Aillon 2008-04-17 23:18:16 EDT
Fixed in F-9
Comment 16 Christopher Aillon 2008-04-17 23:19:10 EDT
*** Bug 187844 has been marked as a duplicate of this bug. ***
Comment 17 Ville Skyttä 2008-04-18 02:50:37 EDT
Thanks.  This last little bit would be beneficial for repeated "rpmbuild -bi
--short-circuit" builds:

-touch ../%{name}.lang
+cat /dev/null > ../%{name}.lang
Comment 18 Matěj Cepl 2008-12-19 07:48:23 EST
*** Bug 477127 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.