This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 187880 - Default photo-viewer is xloadimage
Default photo-viewer is xloadimage
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnupg (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Mike McLean
:
: 189284 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 05:20 EDT by Leonid Kanter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.4.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-11 15:34:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix to find an image viewer at runtime (856 bytes, patch)
2006-04-11 14:41 EDT, David Shaw
no flags Details | Diff

  None (edit)
Description Leonid Kanter 2006-04-04 05:20:53 EDT
Description of problem:

Default photo-viewer is xloadimage which is not shipped with fc5. It should be
changed for other available viewer.

Version-Release number of selected component (if applicable):

gnupg-1.4.2.2-2

How reproducible:

always

Steps to Reproduce:

in key edit mode, enter "addphoto xx.jpg" command

 
Actual results:

/bin/bash: xloadimage: command not found

Expected results:

Photo should be displayed

Additional info:


from /usr/share/gnupg/options.skel:


# The default program is "xloadimage -fork -quiet -title 'KeyID 0x%k' stdin"
# On Mac OS X and Windows, the default is to use your regular JPEG image
# viewer.
#
# Some other viewers:
# photo-viewer "qiv %i"
# photo-viewer "ee %i"
# photo-viewer "display -title 'KeyID 0x%k'"
Comment 1 David Shaw 2006-04-11 14:41:38 EDT
Created attachment 127632 [details]
Fix to find an image viewer at runtime

This will be fixed in GnuPG 1.4.5.  In the meantime, here is a patch.
Comment 2 Nalin Dahyabhai 2006-04-11 15:34:34 EDT
Ohh, that definitely beats my previous plan (straw poll... ugh).  Thanks, David!
Comment 3 Nalin Dahyabhai 2006-04-19 11:51:27 EDT
*** Bug 189284 has been marked as a duplicate of this bug. ***
Comment 4 Nalin Dahyabhai 2006-04-19 11:55:14 EDT
Changing resolution from Raw Hide to Current Release, as this change has been
pushed as an update for FC5.

Note You need to log in before you can comment on or make changes to this bug.