Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1879081 - [CI] 4.6 jobs fail with "`GLIBC_2.28' not found"
Summary: [CI] 4.6 jobs fail with "`GLIBC_2.28' not found"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Martin André
QA Contact: David Sanz
URL:
Whiteboard: [sig-network][Feature:Router] The HAP...
: 1879114 1879116 1879121 1879243 1879926 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-15 12:08 UTC by Martin André
Modified: 2020-10-27 16:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Configured cluster with gu workload attached to SRIOV networks should let resource-aligned PODs have working SRIOV network interface Configured cluster with gu workload saturating NUMA nodes should allow a pod requesting as many cores as a full NUMA node have Configured cluster with gu workload saturating NUMA nodes should guarantee correct allocation with concurrent creation Configured cluster with gu workload saturating NUMA nodes should reject pod requesting more cores than a single NUMA node have Configured cluster with gu workload should guarantee NUMA-aligned cpu cores in gu pods with multiple pods, each with a single container requesting 1 core, 1 device Configured cluster with gu workload should guarantee NUMA-aligned cpu cores in gu pods with multiple pods, each with a single container requesting 2 core, 1 device Configured cluster with gu workload should guarantee NUMA-aligned cpu cores in gu pods with multiple pods, each with multiple containers requesting 1 core, 1 device Configured cluster with gu workload should guarantee NUMA-aligned cpu cores in gu pods with multiple pods, each with multiple containers requesting 1 core, only one requesting 1 device Configured cluster with gu workload should guarantee NUMA-aligned cpu cores in gu pods with single pod, multiple containers requesting 1 core, 1 device each Configured cluster with gu workload should guarantee NUMA-aligned cpu cores in gu pods with single pod, single container requesting 1 core, 1 device Configured cluster with gu workload should guarantee NUMA-aligned cpu cores in gu pods with single pod, single container requesting 4 cores, 1 device
Last Closed: 2020-10-27 16:41:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4175 0 None closed Bug 1879081: OpenStack: Switch to train/centos8 repos 2021-02-15 02:46:50 UTC
Github openshift oc pull 568 0 None closed Bug 1879081: Build cli images with RHEL 7 2021-02-15 02:46:50 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:41:30 UTC

Description Martin André 2020-09-15 12:08:17 UTC
Container images for 4.6 are being migrated to rhel8 and since 2020-09-12, the 4.6 CI jobs fail with:

    oc: /lib64/libc.so.6: version `GLIBC_2.28' not found (required by oc)


This is caused by a mismatch between the `tests` image, providing the `oc` binary, and the `openstack-installer` image running the test, in which we copy the `oc` binary.

Comment 4 Stephen Greene 2020-09-15 19:20:11 UTC
*** Bug 1879121 has been marked as a duplicate of this bug. ***

Comment 5 Joseph Callen 2020-09-15 20:23:53 UTC
*** Bug 1879114 has been marked as a duplicate of this bug. ***

Comment 6 Joseph Callen 2020-09-15 20:24:11 UTC
*** Bug 1879116 has been marked as a duplicate of this bug. ***

Comment 7 Joseph Callen 2020-09-15 20:29:55 UTC
*** Bug 1879243 has been marked as a duplicate of this bug. ***

Comment 8 Petr Balogh 2020-09-16 09:04:31 UTC
What is the status? I tested today latest nightly 4.6  4.6.0-0.nightly-2020-09-16-000734 and failed with the same.

See there is another one: 4.6.0-0.nightly-2020-09-16-050052

So will try this one as well.

Thanks

Comment 9 Petr Balogh 2020-09-16 09:57:08 UTC
I see that with the new nightly build:  4.6.0-0.nightly-2020-09-16-050052 it's working.

At least in our CI we don't see this issue we saw before.
https://ocs4-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/qe-deploy-ocs-cluster/12426/console

So from my point of view it can be moved to verified but I am not QE contact here.

Thanks

Comment 12 Devan Goodwin 2020-09-17 11:57:31 UTC
Working build watcher today, this is still showing up as our top 4.6 failing tests with a pass rate of 0%. Adding the test references to Environment.

Comment 13 Devan Goodwin 2020-09-17 11:57:48 UTC
*** Bug 1879926 has been marked as a duplicate of this bug. ***

Comment 14 David Sanz 2020-09-18 14:32:55 UTC
Verified


$ oc adm release extract --tools registry.svc.ci.openshift.org/ocp/release:4.6.0-0.nightly-2020-09-18-071428

$ tar xzvf openshift-client-linux-4.6.0-0.nightly-2020-09-18-071428.tar.gz 
README.md
oc
kubectl
$ ./oc  version
Client Version: 4.6.0-0.nightly-2020-09-18-071428

Comment 17 errata-xmlrpc 2020-10-27 16:41:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.