Bug 187919 - [KDE] OpenOffice buttonbar buttons "stutter"
[KDE] OpenOffice buttonbar buttons "stutter"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 179059 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-04 11:27 EDT by Scott Baker
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-24 04:08:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
workaround that stops the flickering and similiar problems for me (1.22 KB, patch)
2006-07-10 08:37 EDT, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 50857 None None None Never

  None (edit)
Description Scott Baker 2006-04-04 11:27:42 EDT
Description of problem: Selecting the drop down on the "insert table" button on
the OpenOffice Writer toolbar causes the button to be redrawn about five times.
The button flashes and appears to stutter before showing the options.

Version-Release number of selected component (if applicable): 2.0.2-5.7.2

How reproducible: Easy

Steps to Reproduce:
1. Load OpenOffice writer. 
2. Click the insert table button
3. Watch it flash/flicker
  
Actual results: The button is redrawn several times

Expected results: The button should just drop down without flashing

Additional info: Anything with a drop down: insert table, text color, background
color, etc. flicker a lot. It's annoying and it slows down the process. This bug
appears in all the OOO applications. Writer is just the easiest to test.
Comment 1 Caolan McNamara 2006-04-04 11:35:39 EDT
Under KDE or GNOME. What theme ?
Comment 2 Scott Baker 2006-04-04 12:56:15 EDT
I didn't even think to check that. I'm using KDE, and I experience this "bug"
with the default theme. I have a fresh install of FC5 running KDE in my lab that
has the "stuttering" buttons. So whatever the default theme is. In fact it seems
to do it on at least the two themes I've tested.

I just installed both Gnome and XFCE and neither seem to exhibit this behaviour.
It must be a KDE specific thing.
Comment 3 Caolan McNamara 2006-04-05 04:13:36 EDT
caolanm->than: Do you know if this is a duplicate of any KDE and GNOME theme
bridgeing issue ?
Comment 4 Scott Baker 2006-04-05 11:02:12 EDT
I'm not aware of this issue occuring in any other applications that I've run
thus far. If that helps.
Comment 5 Caolan McNamara 2006-04-05 11:12:16 EDT
If anything else had the same effect, I'd expect it to be, e.g. a gnome
application run in KDE, e.g. gedit. Or another application that uses the OOo
style of following the theme, e.g. mozilla or perhaps java applications.
Comment 6 David Anderson 2006-04-20 14:20:09 EDT
I get this horrible flickering too. I have gtk-qt-engine installed, but not in 
use (instead, I'm using 'ClearLooks').
Comment 7 Caolan McNamara 2006-05-03 07:25:07 EDT
http://www.openoffice.org/servlets/ReadMsg?list=discuss&msgNo=48704 sounds similiar
Comment 8 Scott Baker 2006-05-03 12:17:27 EDT
Wild! I just loaded OpenOffice writer and the problem seems to have gone away.
Since I first posted I now running the "nvidia" driver, not the "nv" driver so
perhaps that's the fix? Maybe "nv" + KDE + OOO has that stutter? I'll try on
another computer and let you know.
Comment 9 Caolan McNamara 2006-05-03 12:33:11 EDT
Your findings tally with that of the mailing list post above, i.e nv driver has
the flicker, nvidia doesn't
Comment 10 Caolan McNamara 2006-07-10 08:36:41 EDT
*** Bug 179059 has been marked as a duplicate of this bug. ***
Comment 11 Caolan McNamara 2006-07-10 08:37:45 EDT
Created attachment 132167 [details]
workaround that stops the flickering and similiar problems for me
Comment 12 Caolan McNamara 2006-07-10 08:40:49 EDT
Added to devel CVS and FC-5 update, will be in next update if one is called for.
Comment 13 Fedora Update System 2006-07-22 15:01:44 EDT
openoffice.org-2.0.2-5.17.2 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 14 Fedora Update System 2006-07-31 15:55:11 EDT
openoffice.org-2.0.2-5.17.2 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 15 Scott Baker 2006-07-31 15:57:44 EDT
Is this bug be present in OpenOffice 2.0.3 which is the current release? When
will that be hitting fedora?
Comment 16 Caolan McNamara 2006-08-01 03:11:38 EDT
2.0.3 is in rawhide (FC6)

Note You need to log in before you can comment on or make changes to this bug.