Bug 187998 - CPU soft lockup at random times
CPU soft lockup at random times
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-04-05 05:55 EDT by Paolo Pelloni
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-19 23:39:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screen Dump of Bug (895 bytes, text/plain)
2006-04-05 05:55 EDT, Paolo Pelloni
no flags Details

  None (edit)
Description Paolo Pelloni 2006-04-05 05:55:24 EDT
Description of problem:
I have a Dell Inspiron 8500 (European) that worked always perfectly under FC4
but freezes completly now under FC5. It doesn't freeze on a specific issue but
from time to time. It can run fine for 10 minutes or 4 hour and then at a
certain point boom CPU lockup. What seems to be consistent is that it does
freeze every single time I run updatedb, even from a text console without
logging in the GDM. 
Attached is the output of the bug on the main terminal, copied by hand since I
couldn't find any trace in the logfiles. dmesg is fine, although I do have
errors from nautilus (but they seem not related to this lockup). 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Paolo Pelloni 2006-04-05 05:55:24 EDT
Created attachment 127336 [details]
Screen Dump of Bug
Comment 2 Paolo Pelloni 2006-04-09 05:09:10 EDT
After further investigation the problem seems to be strictly related to file
operations. It does crash every single time you run updatedb (and before the
random crashes where due to cron scheduled updatedb), but it crashes also when
you use the new desktop search or also when in bash you type like p and the
<tab> (process crashing: bash) beacuse it has to go through a big index of files.
Comment 3 Phil Knirsch 2006-05-12 08:03:28 EDT
This looks like a kernel bug though. The component filesystem is only about bugs
in that respective package which contains a raw directory structure for a
standard system.

Reassigning to proper component.

Read ya, Phil
Comment 4 Dave Jones 2006-10-16 17:08:14 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 5 Michael Jørgensen 2006-11-22 07:00:50 EST
I've just seen something similar on kernel 2.6.18-1.2239.fc5.

I was running a rsync daemon, and transferring a large number of files to a 
client on a different machine.

The output at the client was the following:
mij-6 kernel: Oops: 0002 [#1]
mij-6 kernel: CPU:    0
mij-6 kernel: EIP is at drop_buffers+0x5c/0x8f
mij-6 kernel: eax: cd31b274   ebx: d6a71170   ecx: 00000000   edx: d6a71198
mij-6 kernel: esi: c1297580   edi: d6a71170   ebp: d6a71170   esp: dbf61df8
mij-6 kernel: ds: 007b   es: 007b   ss: 0068
mij-6 kernel: Process kswapd0 (pid: 91, ti=dbf61000 task=dbf00750 
mij-6 kernel: Stack: dbf61e10 da7c6c48 c1297580 00000000 c0654d40 c045bfb8 
00000000 dc8d97e0
mij-6 kernel:        000000d0 00000001 c045c01d c1297580 da7c6bf0 c04473b0 
dbf61f14 00000046
mij-6 kernel:        dbf61f78 00000020 00000000 00000000 00000020 00000002 
00000001 00000000
mij-6 kernel: Call Trace:
mij-6 kernel:  [<c045bfb8>] try_to_free_buffers+0x4d/0x7e
mij-6 kernel:  [<c045c01d>] try_to_release_page+0x34/0x46
mij-6 kernel:  [<c04473b0>] shrink_inactive_list+0x454/0x697

However, on the console screen I saw the following (copied by hand)
[<c0444546>] __alloc_pages+0x190/0x292
[<c0331362>] generic_file_buffered_write+0x19e/0x5f1
[<dc8d5fbc>] ext3_file_write+0x24/0x90 [ext3]
BUG: soft lockup detected on CPU#0!

The system I'm running on is a VIA EPIA EN12000E motherboard with a VIA Eden 
CPU and a VIA VT8237R chipset.

I've only seen this once.
Comment 6 Dave Jones 2006-11-24 15:48:12 EST
Michael, your soft lockup is the symptom of a bigger problem (The oops).  Can
you open a seperate bug, and see if this made it to the logs, as there's some
parts of the kernel messages that seem to be missing.
Comment 7 Jon Stanley 2008-01-19 23:39:10 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.