Bug 188004 - Firefox beagle extension crashes javascript unless beagled running
Firefox beagle extension crashes javascript unless beagled running
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-05 07:13 EDT by Felix Bellaby
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-05 07:40:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Bellaby 2006-04-05 07:13:44 EDT
Description of problem:
Firefox beagle extension often crashes javascript unless beagled is running

Version-Release number of selected component (if applicable):
beagle-0.2.3-4

How reproducible:
Using firefox with many sites while javascript is enabled causes firefox to
crash unexpectedly, but only when beagle extension is included and beagled is
unavailable.

Steps to Reproduce:
1. Kill beagled
2. Start Firefox with beagle extension still in place
3. Try visiting a few websites that use javascript intensively.
  
Actual results:
Firefox crashes

Additional info:
I have not sought to investigate how this crash is happening in any detail,
but including javascript extensions in firefox which try to access a
non-existent server seems quite likely to cause problems. Firefox does not
produce any debugging output by default when these crashes occur.

This is problem is related to the stop gap solution employed to counter
bug 183898, which means that beagled is not started by default, and made
worse by bug 186179, which makes beagled difficult to start automatically.

If this problem appears reproducible, then it would seem sensible to remove the
beagle extension from firefox as a stop gap.

I will investigate a little further, one I have finished using Firefox to post
this report :).
Comment 1 Felix Bellaby 2006-04-05 07:40:13 EDT
Further testing suggests that I am probably wrong to be blaming beagle for this
bug. I have been able to eliminate crashes on some sites by running beagled or
removing the beagle extension to Firefox. However, I am still getting crashes
when visiting sites like http://www.anandtech.com whenever javascript is
enabled.  Therefore, it appears that my problem lies in Firefox, and beagle was
only causing specific problems because it uses javascript in its implementation. 

I am reassigning this to NOTABUG

Note You need to log in before you can comment on or make changes to this bug.