Bug 1880492 - Topology list view shows empty application groups when all children are filtered
Summary: Topology list view shows empty application groups when all children are filtered
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jeff Phillips
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-18 16:51 UTC by Jeff Phillips
Modified: 2020-10-27 16:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.nightly-2020-09-18-071428 Cluster ID: 55a3a819-1038-462d-8020-f9288c70a905 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36
Last Closed: 2020-10-27 16:42:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
Topology list view does not shows empty application groups when all children are filtered (1.07 MB, video/webm)
2020-09-24 20:31 UTC, spathak@redhat.com
no flags Details
Topology list view does not shows empty application groups when all children are filtered (1.07 MB, video/webm)
2020-09-25 11:13 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6681 0 None closed Bug 1880492: Fix topology list view to not show empty application groups 2020-09-23 10:36:24 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:43:15 UTC

Description Jeff Phillips 2020-09-18 16:51:50 UTC
Description of problem:

The topology list view shows all application groups even if all the children of the group have been filtered


Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:

1. Create a project with multiple application groupings with various resources.
2, Navigate to Topology and go to the list view
3. Use the Filter by Resource dropdown and filter out all resource types belonging to an application group

Actual results:

The application group shows with no children

Expected results:

The application group is not shown

Additional info:

Comment 2 spathak@redhat.com 2020-09-23 14:46:23 UTC
Blocked for validation by https://bugzilla.redhat.com/show_bug.cgi?id=1881934

Comment 3 spathak@redhat.com 2020-09-24 20:31:36 UTC
Created attachment 1716444 [details]
Topology list view does not shows empty application groups when all children are filtered

Comment 4 spathak@redhat.com 2020-09-24 20:32:26 UTC
Verify on build version: 4.6.0-0.nightly-2020-09-24-095222
Browser version: Chrome 84

Comment 5 spathak@redhat.com 2020-09-25 11:13:59 UTC
Created attachment 1716597 [details]
Topology list view does not shows empty application groups when all children are filtered

Comment 8 errata-xmlrpc 2020-10-27 16:42:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.