Bug 188145 - No option to retry when opening package fails
No option to retry when opening package fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: Regression
: 191301 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-04-06 09:23 EDT by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-17 18:11:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2006-04-06 09:23:47 EDT
We always used to be able to do network installs without a full set of RPMS
downloaded in advance -- if the installer wanted one which wasn't present, it'd
complain and its error dialog box would have a 'retry' button. So you could
fetch the missing RPM and click 'retry' and continue on your merry way....

It doesn't do that any more. The only option is 'reboot'.
Comment 1 Chris Lumens 2006-04-06 11:15:49 EDT
In a lot of cases, we are already retrying multiple times before popping up an
error message.  We're using urlgrabber which has retry support.  However,
there's still room for improvement.
Comment 2 David Woodhouse 2006-04-06 11:29:56 EDT
Retrying before you pop up the dialog box which tells me which package you want
me to fetch and add to the Fedora/RPMS/ directory isn't going to work. You need
to tell me what you want and _then_ retry after I click the 'retry' button
(which doesn't exist any more).
Comment 3 Chris Lumens 2006-05-17 14:03:49 EDT
*** Bug 191301 has been marked as a duplicate of this bug. ***
Comment 4 Paul Nasrat 2006-07-17 18:11:09 EDT
This should be much better in FC6t1 and later.

Note You need to log in before you can comment on or make changes to this bug.