Bug 191301 - Anaconda forces reboot if it cannot read an rpm from CD
Summary: Anaconda forces reboot if it cannot read an rpm from CD
Status: CLOSED DUPLICATE of bug 188145
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 186145 (view as bug list)
Depends On:
Blocks: FC6Blocker
TreeView+ depends on / blocked
 
Reported: 2006-05-10 16:49 UTC by Pavel Roskin
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 18:03:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel Roskin 2006-05-10 16:49:48 UTC
Description of problem:
If a badly written CD is inserted, anaconda forces reboot instead of prompting
the user to replace the disk

Version-Release number of selected component (if applicable):
anaconda-11.0.5-1.ppc.rpm (or whatever is used on the PowerPC FC5)

How reproducible:
It happended the first and the only time I tried

Steps to Reproduce:
1. Start install from a good discs 1,2,3
2. Write truncated disk 4
3. Insert that disk when prompted
  
Actual results:
Reboot is the only option.  The text console shows that expat-devel couldn't be
installed.

Expected results:
User should be prompted to replace the disk.  It's easier to rewrite disk 4 that
to babysit the machine again through the install.

Additional info:
The bug is similar but distinct from bug #183974, which deals with network
installs.  Please don't forget to unlock the CD when prompting for replacement.

Comment 1 Jeremy Katz 2006-05-15 18:37:39 UTC
*** Bug 186145 has been marked as a duplicate of this bug. ***

Comment 2 Jeremy Katz 2006-05-15 18:40:10 UTC
We really need to fix the retry logic for FC6

Comment 3 Chris Lumens 2006-05-17 18:03:23 UTC

*** This bug has been marked as a duplicate of 188145 ***


Note You need to log in before you can comment on or make changes to this bug.