Bug 188148 - graphviz is broken
graphviz is broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: graphviz (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jima
Fedora Extras Quality Assurance
:
: 197236 (view as bug list)
Depends On:
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-04-06 09:46 EDT by Sonal Santan
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.8-4.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 22:01:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sonal Santan 2006-04-06 09:46:16 EDT
Description of problem:
dotty provided by graphviz-2.8-3.fc5 does not work since lefty is missing from
the package. I get the following output when running dotty--

prompt>which dotty
/usr/bin/dotty
prompt>dotty /usr/share/graphviz/graphs/directed/alf.dot
which: no lefty in
(.:/sbin:/usr/sbin:/usr/local/sbin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/usr/local/jre1.5.0_05/bin)
dotty: cannot locate the lefty program
       make sure that your path includes
       the directory containing dotty and lefty


Version-Release number of selected component (if applicable):
graphviz-2.8-3.fc5


How reproducible:
Always reproduceable.

Steps to Reproduce:
1.prompt> dotty /usr/share/graphviz/graphs/directed/alf.dot
2.
3.
  
Actual results:
dotty errors out.

Expected results:
dotty should display the graph.

Additional info:
Comment 1 Alex Lancaster 2006-09-14 11:22:57 EDT
This package has been broken for 5 months, please fix this ASAP!  Is this
package orphaned? There is also a duplicate at bug #197236.
Comment 2 Jima 2006-09-14 11:53:21 EDT
*** Bug 197236 has been marked as a duplicate of this bug. ***
Comment 3 Topher 2006-09-14 18:13:18 EDT
Is the fix really not as simple as it appears?
Comment 4 Jima 2006-09-14 22:01:43 EDT
It was pretty simple, actually.  Alex came into #fedora-extras this morning
looking for help on this issue, and I rolled an update, resolving this and
#184171.  I inadvertantly created another bug (if only one) in the process, but
it's not a blocker, and if this package goes orphan next week, I'll likely take
over and do another round of cleanups.

Note You need to log in before you can comment on or make changes to this bug.