This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 188169 - "locate pointer" mouse preference interferes with vncviewer's ctrl keys
"locate pointer" mouse preference interferes with vncviewer's ctrl keys
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
David Lawrence
:
: 183401 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 13:02 EDT by Robert Peterson
Modified: 2013-04-30 19:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 04:05:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
locate pointer preference doesn't interfere ctrl key in vncviewer now (1.13 KB, patch)
2006-08-29 09:30 EDT, Adam Tkac
no flags Details | Diff

  None (edit)
Description Robert Peterson 2006-04-06 13:02:27 EDT
Description of problem:
If you turn on the "Locate Pointer" feature in mouse preferences, it
will cause vnc viewer sessions to interpret control keys as non-control
keys.  So pressing "ctrl-c" in a terminal window, will produce the
letter "c".  Ctrl-X in xemacs will produce the letter "x" in the editor,
and so forth.

How reproducible:
Always.

Steps to Reproduce:
1. Desktop -> Preferences -> Mouse
2. Select the "Cursors" tab
3. Check the "Locate Pointer" checkbox.
4. Go into vncviewer, control a remote session
5. Open a terminal session and at the command prompt, press ctrl-c.  

Actual results:
The command prompt gives you a "c".  For example, you'll see:
[root@void ~]# c

Expected results:
Another prompt should appear.  For example, you should see:
[root@void ~]#
[root@void ~]#
Comment 1 Jitka Kozana 2006-07-17 04:00:14 EDT
*** Bug 183401 has been marked as a duplicate of this bug. ***
Comment 2 Adam Tkac 2006-08-29 09:30:17 EDT
Created attachment 135127 [details]
locate pointer preference doesn't interfere ctrl key in vncviewer now
Comment 3 Fedora Update System 2006-10-20 15:25:32 EDT
vnc-4.1.2-4.fc7 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Adam Tkac 2006-10-24 03:39:38 EDT
oops, sorry for comment #3. vnc-4.1.2-4.fc6 has been pushed for fc6
Comment 5 Adam Tkac 2007-04-23 10:43:53 EDT
After next problems related to this I have to remove this patch and close this
like WONTFIX

Regards, -A-

Note You need to log in before you can comment on or make changes to this bug.