Bug 18817 - RHN Configuration with http proxy
RHN Configuration with http proxy
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
:
: 19317 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 10:31 EDT by angus young
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-20 11:33:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description angus young 2000-10-10 10:31:51 EDT
RHN Configuration registration problem.
We have an internet connexion by an HTTP proxy. This systeme work fine with
Netscape, Helix Gnome updater, etc..
In the update-config, there is no reference to an HTTP Proxy, but in the
/etc/sysconfig/rhn/up2date there is a value for proxy that I have modified
to reflate our configuration:
pkgProxy=http://192.168.98.254:8080 and enableProxy=1
But there is no success.
Have an idea ?
Comment 1 Preston Brown 2000-10-10 11:53:46 EDT
Can you please try specifying your serverURL in /etc/sysconfig/rhn/up2date as:

http://your.proxy.here/https://www.rhns.redhat.com/XMLRPC

And let me know if that works?
Comment 2 Richard Tango-Lowy 2000-10-30 23:50:07 EST
I'm having the same problem. I tried your fix for the serverURL line and got the
following error when I try to register:

"There was a fatal error communicating with the server. The message was: Proxy
denies fulfilling the request."

I tried this with the enableProxy variable set to both 0 and 1. Same response.

Sincerely,

Rich Tango-Lowy
Agilent Technologies
Comment 3 angus young 2000-11-02 03:14:08 EST
tested your proposition with no success when launched up2date or rhn_register.
i precise that it works with helix-update. Why not use the same code, it's GPL.
Comment 4 angus young 2000-11-02 03:59:51 EST
When attempt to browse with netscape this URL:
http://192.168.98.254:8080/http://www.redhat.com
where 192.168.98.254:8080 is our proxy (netscape proxy server)
I have got the same error that i have with up2date:

Proxy denies fulfilling the request
The proxy's access control configuration denies access to the requested object
through this proxy.
Comment 5 angus young 2000-11-22 14:07:07 EST
any help will be appreciate.
we have 60 redhat workstation that i hope we could register to the redhat
network one day, and in fact use the up2date package.
Comment 6 Preston Brown 2000-11-27 16:03:47 EST
a new version of update agent will be released this week with proxy support
included.
Comment 7 Preston Brown 2000-11-28 11:15:58 EST
*** Bug 19317 has been marked as a duplicate of this bug. ***
Comment 8 angus young 2000-11-28 12:18:20 EST
let there be light,
there was light
8)
which good news
i know no information is better than misinformation
but a such silence is connected as Micro$oft
Comment 9 angus young 2000-12-12 07:44:21 EST
one week last, nothing on updates.redhat.com & redhat-watchlist.
Is there any new problem with the so much waited up2date with http proxy
support.
Comment 10 angus young 2000-12-13 15:59:33 EST
My RHN Register report
RHBA-2000:124-01
Numerous bugfixes and enhancements have been made to Update Agent since the
release of Red Hat Linux 7.0. While not a required upgrade, it is suggested.
But cannot download it.
Verification refer to python-xmlrpc-1.2-1.i386.rpm
RedHat 7.0:python-xmlrpc-1.0-8.i386.rpm
So do we wait python-xmlrpc-1.2 release in stable tree or apply rawhide
12/12/2000 python-xmlrpc, up2date-2.1.6-1
Comment 11 angus young 2000-12-18 07:17:05 EST
tested new RPM from rawhide (12-12-2000)
up2date-2.1.6-1.i386.rpm
up2date-gnome-2.1.6-1.i386.rpm
python-xmlrpc-1.2-1.i386.rpm

with no success

this is the message i have with invocate
up2date in console mode

up2date -r
There was a fatal error communicating with the server.  The message was:
nonnumeric port

good  proxy URL in /etc/sysconfig/rhn/up2date

rawhide doesn't have any new rhn_register RPM
so RedHat Network registering other than web access isn't possible.
Comment 12 angus young 2000-12-20 11:33:23 EST
up2date appears to work but is very slow in comparaison of a connexion whithout
proxy.

so there remains the problem of rhn_register which could not negociate a
connexion by HTTP proxy.
Comment 13 Preston Brown 2000-12-21 14:33:22 EST
the new version of up2date is being officially released today and includes proxy
support.  A new version of rhn_register is also being made available, and it
includes proxy support.
Comment 14 Michael Jouannigot 2001-01-19 06:49:33 EST
is up2date currently being modified to accept HTTP proxy with user/pass access ?
Comment 15 Need Real Name 2001-04-06 09:18:48 EDT
What to do when the proxy is configured with a user and password
Where can I add that to the proxy setting

Now I got the error message: unable to set up CONNECTION tunnel
Comment 16 Need Real Name 2002-03-06 20:49:50 EST
my 7.2 attempts to use a proxy and issues the error message:

A protocol error occured: Proxy Error , attempt #1
A protocol error occured: Proxy Error , attempt #2
A protocol error occured: Proxy Error , attempt #3
A protocol error occured: Proxy Error , attempt #4
A protocol error occured: Proxy Error , attempt #5

even though i have not enabled the proxy config
Comment 17 Need Real Name 2002-10-04 14:26:32 EDT
We've been experiencing similar problems running up2date from behind a 
firewall. We had all the correct proxy information in the up2date configuration 
file, but we kept getting the following error 5 times when we ran rhn_register 
from the command line: "A socket error occurred: Unable to set up CONNECTION 
tunnel" -- and, you can't run the up2date app without registering with RedHat. 
(what it seems at least...)

We viewed the rhn_register file and saw that there were manual proxy parameters 
that could be run. This did the trick for us. We are now able to run up2date 
successfully.

Do "rhn_register --help" (without quotes) from the command line for complete 
details. Hope this helps others experiencing the same problem.
Comment 18 Need Real Name 2002-10-04 14:29:47 EDT
NOTE: Forgot to mention that this is for version RH Linux 7.3 for the above 
problem.

Note You need to log in before you can comment on or make changes to this bug.