Bug 188197 - nash fails to mknod cciss and i2o devices
nash fails to mknod cciss and i2o devices
Status: CLOSED DUPLICATE of bug 196360
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 16:36 EDT by Yuri Gelfand
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 17:28:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yuri Gelfand 2006-04-06 16:36:55 EDT
Description of problem:

This occures via a basic initial installation of FC5 (only tried x86_64, but I
assume possibly others), via the default (5.0.32) mkinitrd.  nash (or more
specifically mkblkdevs) fails to create /dev/cciss/* block devs when in
initrd:/init.  This appears to be due to the move to use of sys/block reading,
and I can only assume that /dev/cciss!cXdXpX nodes are created instead. 
Installations however, uses /dev/cciss/cXdXpX as rootfs.

How reproducible:


Steps to Reproduce:
1. Install FC5 w/ rootfs on a device requiring cciss.ko
2. Boot Machine
  
Actual results:

Unable to find rootfs, kernel panic.

Expected results:

Machine boots properly, no kernel panic.

Additional info:

Manually added

mkdir /dev/cciss
mknod /dev/cciss/cXdXpX b MAJ, MIN

to initrd:~init right before call to mkrootdev, and system boots just fine.
Comment 1 Adrian Reber 2006-04-20 11:31:13 EDT
I have the same problem with i2o devices, they are also in a subdirectory
(/dev/i2o) and mkblkdevs creates them as /dev/i2o!hda instead of /dev/i2o/hda.

This worked on FC4 and that's why I am still using a FC4 kernel.

I am having this problem on i386.
Comment 2 Peter Jones 2006-08-16 17:28:46 EDT

*** This bug has been marked as a duplicate of 196360 ***

Note You need to log in before you can comment on or make changes to this bug.