Bug 196360 - (fc6-cciss) Kernel panic on cciss caused by nash change in mkinitrd
Kernel panic on cciss caused by nash change in mkinitrd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
: 188197 200542 201746 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-06-22 15:14 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 12:08:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot via remote management chip (10.96 KB, image/png)
2006-06-22 15:16 EDT, Robert Scheck
no flags Details
Diff between working and non-working code to locate the problem (830 bytes, text/plain)
2006-06-22 15:21 EDT, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2006-06-22 15:14:50 EDT
Description of problem:
Your last change in nash/lib.c made mkinitrd absolutely unusable for cciss 
devices (which means HP Smart Arrays). Every initrd created with mkinitrd after
your last change to nash/lib.c change will result everytime in a kernel panic...

Version-Release number of selected component (if applicable):
mkinitrd-5.0.43

How reproducible:
Everytime, just install a kernel package when you've got a cciss/HP Smart Array 
system and try to boot it.

Actual results:
Kernel panic on cciss caused by nash change in mkinitrd :-(

Expected results:
Would be very nice, if you could fix your broken code very soon ;-)

Additional info:
I'm able to provide any filesystem & path information and system outputs - as 
long as I don't have to reboot the machine for, sorry.
Comment 1 Robert Scheck 2006-06-22 15:16:54 EDT
Created attachment 131376 [details]
Screenshot via remote management chip
Comment 2 Robert Scheck 2006-06-22 15:21:01 EDT
Created attachment 131377 [details]
Diff between working and non-working code to locate the problem

mkinitrd-5.0.43/nash/lib.c contains the broken code causing this bug report,
code from mkinitrd-5.0.32/nash/lib.c is working very well - have a lot of fun
when fixing this... ;-)
Comment 3 Robert Scheck 2006-07-19 16:49:24 EDT
Ping? IMHO this is a regression and should be a FC6Blocker...
Comment 4 Peter Jones 2006-08-01 16:25:50 EDT
*** Bug 200542 has been marked as a duplicate of this bug. ***
Comment 5 Peter Jones 2006-08-16 17:12:10 EDT
*** Bug 201746 has been marked as a duplicate of this bug. ***
Comment 6 Peter Jones 2006-08-16 17:28:49 EDT
*** Bug 188197 has been marked as a duplicate of this bug. ***
Comment 7 Peter Jones 2006-09-13 16:20:36 EDT
Currently this works for me -- are you still seeing it?
Comment 8 Robert Scheck 2006-09-23 11:23:00 EDT
Did you try both,

  kernel /vmlinuz ro root=LABEL=/

and e.g.

  kernel /vmlinuz ro root=/dev/cciss/c0d0p1

because normally one of these always was broken. And It would be easier to me if 
you could provide a (unified) diff of the relevant part which (sh|c)ould solve 
the problem.
Comment 9 tibyke 2006-09-24 04:18:48 EDT
yeah, Robert is right, LABEL=/ works, but /dev/cciss/whatever just causes a
kernel panic.
Comment 10 Peter Jones 2006-09-28 12:08:49 EDT
Should work in mkinitrd-5.1.19-1 .

Note You need to log in before you can comment on or make changes to this bug.