Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1882232 - Couldn't get ES indices with cluster-admin user's token
Summary: Couldn't get ES indices with cluster-admin user's token
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
: 1882255 1884201 (view as bug list)
Depends On:
Blocks: 1884450
TreeView+ depends on / blocked
 
Reported: 2020-09-24 06:27 UTC by Manish Pandey
Modified: 2020-10-27 15:13 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:12:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin-aggregated-logging pull 1994 0 None closed Bug 1882232: Enable admin_reader to monitor cluster 2021-01-20 01:55:02 UTC
Red Hat Product Errata RHBA-2020:4198 0 None None None 2020-10-27 15:13:15 UTC

Comment 1 Jeff Cantrill 2020-09-24 13:17:52 UTC
*** Bug 1882255 has been marked as a duplicate of this bug. ***

Comment 2 Jeff Cantrill 2020-09-25 13:57:27 UTC
*** Bug 1882255 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Cantrill 2020-10-01 13:08:25 UTC
*** Bug 1884201 has been marked as a duplicate of this bug. ***

Comment 7 Anping Li 2020-10-09 15:45:41 UTC
Verified on clusterserviceversion.operators.coreos.com/elasticsearch-operator.4.6.0-202010081538.p0. The kubeadmin,and user with cluster-admin,cluster-reader can get indices with their token.

Comment 12 errata-xmlrpc 2020-10-27 15:12:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.1 extras update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4198


Note You need to log in before you can comment on or make changes to this bug.