Bug 188348 - Printout zoomed by 75% (printout smaller then requested)
Printout zoomed by 75% (printout smaller then requested)
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2006-04-08 03:44 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-06-20 09:30:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
the requested ppd file (20.41 KB, text/plain)
2006-04-08 05:52 EDT, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2006-04-08 03:44:35 EDT
This was initially discussed in bug 186954, but since it is a seperate issue the
creation of a new bug was requested. Not sure if this is cups or another
printing component. In bug 186954 the problem was described as follows:

The print of a pdf exported from ooo is much smaller
then when printing directly from ooo. The pdf looks fine in xpdf, but it as if
its shrunken / zoomed out when printing. This could the printable area problem.

Basicly it looks as if the image is zoomed by 75 %  and the centered. The queue
is an HPC 1350 in black and white mode with paper set to A4, I've tried pdf's
exported from ooo with both the paper size set to letter and to A4 in ooo both
with the same result. I'm using xpdf to print them.

I've tried removiing the queue, apply-> exit system-config-printer and then
recreating it (with the same name though). No help.
Comment 1 Tim Waugh 2006-04-08 05:25:10 EDT
"the printable area problem": could you explain that to me in terms of what you
see and in which dialog?  I saw this paragraph that Ralf Ertzinger wrote on

> Same here (cups to a PS printer via SMB). Cups test page works, and claims
> that the imageable area is 260x367mm, which is plainly ridiculous (this is
> an A4 printer), although I do now know where those numbers come from.

What do you see from a printed test page?
Comment 2 Hans de Goede 2006-04-08 05:46:07 EDT
with "the printable area problem" I indeed meant Ralf's mail.

For me the CUPS testpage says page size: 10.18x14.08 inch, 258.5x375.5 mm. Which
is way to large for an A4 page. The testpage does fill most of the A4 unlike the
pdf prints.

Also the rulers at the top/bottom and left/right or way off the top ruler starts
16 mm from the left margin and 20 mm from the left side of the page. The right
side ruler starts 28 mm from the bottom margin and 40 mm from the bottom of the
page. The rulers do go all the way to the right / top margin.

The scale of the rulers is of too 100 mm on the ruler is only 79 mm in the real
world. Both rulers do have an indentical scale.

This is probably due to the mis reported resolution, according to the testpage
the resolution is 236x236dpi which should be 300x300.

The lower-left and upper rights reports also are strange: lower-left:
-21.2 x -36.1 mm Notice the minus signs! upper right: 237.3 x 321.4 mm

I Also tried to print the trustworhty old redhat A4 testpage, this only shows a
very small upper left corner of what I believe should be the 1 cm border of this
page the part show is far of from 1 cm of the pages borders.

I hope this helps.
Comment 3 Tim Waugh 2006-04-08 05:47:49 EDT
Remind me what version of the cups RPM package you have?

Also, would you mind attaching the PPD file for that queue?  It's in
/etc/cups/ppd/{queuename}.ppd.  Thanks.
Comment 4 Hans de Goede 2006-04-08 05:52:26 EDT
Created attachment 127501 [details]
the requested ppd file

As requested the ppd file, I upgraded to the latest rawhide this morning:
[hans@shalem ~]$ rpm -q cups
[hans@shalem ~]$

I did do a "service cups restart" after the upgrade I didn't rerun /recreate
the queue though since system-config-printer was unchanged from yesterday.

I'm afraid I won't be able to respond to your next request so quickly as I'm
leaving my terminal for 1 to 2 hours. But I will get back to you eventually if
you've got more questions.
Comment 5 Tim Waugh 2006-04-08 06:59:30 EDT
1. In xpdf, what is the command line used to print the file?
2. Also, what does 'lpoptions' say?
Comment 6 Hans de Goede 2006-04-08 07:31:49 EDT
1: "lpr" no more, no less
[hans@shalem FC-5]$ lpoptions
job-sheets=none,none printer-info='HPC 1350 in zwart-wit mode'
printer-is-accepting-jobs=1 printer-is-shared=1 printer-make-and-model='HP PSC
1300 Foomatic/hpijs (recommended)' printer-state=3
printer-state-change-time=1144488887 printer-state-reasons=none
printer-type=167948 cpi=12 fitplot=true lpi=7 page-bottom=86 page-left=57
page-right=57 page-top=72 scaling=100 wrap=true
[hans@shalem FC-5]$
Comment 7 Tim Waugh 2006-04-08 08:41:33 EDT
Does printing with 'lpr -ofitplot=false' make any difference?
Comment 8 Hans de Goede 2006-04-08 09:13:05 EDT
Yes it does, for the ooo created pdf the printout with this cmdline is identical
as when printing directly from pdf.
Comment 9 Tim Waugh 2006-04-08 14:53:43 EDT
Ah!  The 'fitplot' option now interacts with page-{bottom,left,right,top} in a
way it didn't before.

These options are getting set by system-config-printer when it creates a new
queue.  I'm going to make a system-config-printer update for FC-5 that does not
do that.
Comment 10 Tim Waugh 2006-06-20 09:30:42 EDT
This was released.  I think had the fix (only applies to newly created

Note You need to log in before you can comment on or make changes to this bug.