Bug 188437 - We need to come up with a better way to expose Suspend, Hibernate, Standby, etc, to users
We need to come up with a better way to expose Suspend, Hibernate, Standby, e...
Status: CLOSED DUPLICATE of bug 190791
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC6Target FC6Desktop
  Show dependency treegraph
 
Reported: 2006-04-09 19:12 EDT by Paul Bolle
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 14:44:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Bolle 2006-04-09 19:12:57 EDT
Description of problem:
Shut Down... / Suspend actually hibernates

Version-Release number of selected component (if applicable):
gnome-panel-2.14.0-1

How reproducible:
Always

Steps to Reproduce:
1. Shut Down... / Suspend
2.
3.
  
Actual results:
Machine suspends (a.k.a. suspend to memory)

Expected results:
Machine hibernates (a.k.a. suspend to disk)

Additional info:
The present suspend/hibernate/etc. setup is new to me so I might be overlooking
something here. However, the patch found at
http://cvs.fedora.redhat.com/viewcvs/rpms/gnome-panel/FC-5/gnome-panel-2.14.0-gpm-integration.patch?rev=1.1&view=auto
seems (I've only read it through webcvs) to add a Suspend button if the machine
"CanHibernate"  and links this button to a "Hibernate" dbus call.

I'd say the button should either be renamed to "Hibernate", or the button should
be linked to a Suspend (to memory) call. (There could also be both a Hibernate
and a Suspend button, but that might make the dialog crowded.)
Comment 1 Ray Strode [halfline] 2006-04-09 19:57:45 EDT
This is a known issue, but there hasn't been a bug report until now. Thanks.

The problem is we didn't have a translated version of Hibernate.  The logic
behind choosing "Suspend" (which is a bit flawed) was something like "Suspend is
a general term that can mean Suspend-to-ram, which is sometimes called Sleep,
and Suspend-to-disk, which is sometimes called Hibernate".  In truth, the words
are mixed and confused quite a bit and that definition isn't the only one people
use.   We need to come up with something better, but we really need to do it in
upstream GNOME.  There is no reason we should be diverging from upstream like we
are now.

Note we have another entry called "Suspend" in the System menu which means
suspend-to-ram.

Adding to FC6 Tracker.
Comment 2 Matthias Clasen 2006-07-06 18:03:33 EDT
Add to FC6Destop tracker
Comment 3 Mark McLoughlin 2006-07-13 06:03:53 EDT
See also bug #190791
Comment 4 Ray Strode [halfline] 2006-07-19 14:44:50 EDT

*** This bug has been marked as a duplicate of 190791 ***

Note You need to log in before you can comment on or make changes to this bug.