Bug 188451 - Possible problem with growisofs and Pioneer DVR-109
Possible problem with growisofs and Pioneer DVR-109
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 02:39 EDT by Raoul
Modified: 2015-01-04 17:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-12 01:46:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raoul 2006-04-10 02:39:28 EDT
Description of problem:
I have marked this bug as of "high" severity as it leads to computer freeze and
consequently to possible loss of data on my machine.
When I try to burn DVDs either from the nautilus burn tool or by using growisofs
directly, there is a high possibility that the burning process does not start,
and the DVD-writer led stays on until the pc freezes completely after about 1
minute. The possibility of such failure raises if I explicitely set the writing
speed either in GNOME or when issuing growisofs from the cli.

This situation does not happen always.

My DVD writer model is Pioneer DVR-109 with the latest firmware loaded.

The most important thing is that I noticed this bad behaviour from the time I
started using the Rawhide version (fc4->fc5), but it seems that it is still an
issue for me with the FC5 final.

I have tried to play with the drive's options using hdparm (-c -d -u), but it
did not help. Also tried with and without setting the "burnfree" option in the
gnome configurator.

Version-Release number of selected component (if applicable):
dvd+rw-tools.i386    version: 5.21.4.10.8-6.2.1

How reproducible:
It happens frequently. Not always.

Steps to Reproduce:
1. I create an ISO image with mkisofs
2. Try to burn it with growisofs or nautilus burn tool
3. Sometimes the burning process does not start and the computer freezes (i'm
running as unpreviledged user)


Actual results:
Computer freezes some of the times

Expected results:
The burning process should start normally

Additional info:
I do not have the knowledge to investigate this more, but I am open to suggestions.
Comment 1 Raoul 2006-04-10 04:28:26 EDT
Here is a small part of the /var/log/messages. This happens when i try to burn
an image with growisofs:

Apr 10 09:56:56 galeon kernel: cdrom: This disc doesn't have any tracks I recognize!
Apr 10 09:59:19 galeon kernel: hdc: irq timeout: status=0xd0 { Busy }
Apr 10 09:59:19 galeon kernel: ide: failed opcode was: unknown
Apr 10 09:59:19 galeon kernel: hdc: DMA disabled
Apr 10 09:59:49 galeon kernel: hdc: ATAPI reset timed-out, status=0x80
Apr 10 09:59:49 galeon kernel: hdd: DMA disabled
Apr 10 10:00:19 galeon kernel: ide1: reset timed-out, status=0x80
Apr 10 10:00:25 galeon kernel: hdc: status timeout: status=0x80 { Busy }
Apr 10 10:00:25 galeon kernel: ide: failed opcode was: unknown
Apr 10 10:00:25 galeon kernel: hdc: drive not ready for command
Apr 10 10:00:55 galeon kernel: hdc: ATAPI reset timed-out, status=0x80
Apr 10 10:00:56 galeon kernel: ide1: reset: master: error (0x30?)

Comment 2 Dave Jones 2006-10-16 15:31:36 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 3 Raoul 2006-10-19 10:07:26 EDT
Summary of previous problem:
- boot
- burn the 1st DVD = success
- burn a 2nd/3rd etc DVD = failure

Unfortunately, I did not have enough free time to test it more extensively, but
it seems that with the latest kernel (2.6.18-1.2200.fc5), as suggested by Dave
Jones, I can burn more than one DVDs without problems.
- I blanked and burned an ISO image to a DVDRW multiple times without problems.
- I erased and burned the image using the nautilus burn tool without problems.

This kernel is good. Problems have vanished.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.