Bug 18847 - UI should not block while downloading updates
Summary: UI should not block while downloading updates
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords: FutureFeature
: 24335 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-10 20:31 UTC by rh-devel
Modified: 2015-01-07 23:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 01:33:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:048 normal SHIPPED_LIVE New Update Agent with many fixes and enhanced functionality available 2001-04-12 04:00:00 UTC

Description rh-devel 2000-10-10 20:31:18 UTC
Granted it's nontrivial to implement, but when up2date is obtaining an
updated package list, the UI is blocked.  Without some external indication
of network activity (modem lights or something), the behavior is externally
indistinguishable from an app hang for as long as it takes to download the
package list.  Over a modem, that's 15-30sec, too long for a UI to stick.
Obviously a percentage-complete download progress indicator would be ideal,
but just a back-and-forth progress ticker thing would do, esp. if the
operation is made abortable from the UI, and could be done readily by
forking a download process.

Comment 1 Cristian Gafton 2001-02-20 01:33:07 UTC
Assigned QA to jturner

Comment 2 Preston Brown 2001-02-26 23:39:55 UTC
this has improved dramatically in rawhide versions of up2date.  A new stable
release with these changes will be forthcoming.

Comment 3 Preston Brown 2001-02-26 23:49:57 UTC
*** Bug 24335 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.