Bug 188511 - Boot fails to proceed to graphical login screen
Boot fails to proceed to graphical login screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-10 15:45 EDT by D Huen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 20:10:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log when booting with kernel-2.6.16-1.2069_FC4 (fails) (45.24 KB, text/plain)
2006-04-10 15:45 EDT, D Huen
no flags Details
Log from a successful boot (kernel-2.6.15-1.1833_FC4) (37.73 KB, text/plain)
2006-04-10 15:47 EDT, D Huen
no flags Details

  None (edit)
Description D Huen 2006-04-10 15:45:16 EDT
Description of problem:
After upgrading kernel to kernel-2.6.16-1.2069_FC4, bootup fails at point when
it would normally switch over to graphical boot.  This problem does not occur
when booting with kernel-2.6.15-1.1833_FC4 or earlier.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37.FC4.49.2

How reproducible:
Always

Steps to Reproduce:
1. Select kernel-2.6.16-1.2069_FC4 at startup.
2. Screen goes blank and video feed is lost.
3.
  
Actual results:
Blank screen.

Expected results:
Bootup to graphical login screen.

Additional info:
The machine is accessible via ssh even when screen is blank.  Also, if booting
in text mode (initdefault=3), the boot process will proceed to a working VT
login prompt.  When logged in, startx will start the KDE environment normally.

Apparently different from bug #169637 in that workarounds listed there do not
work here (e.g. commenting out load "dri"). 

Differs also from bug #187627 in that the kernel appears to have booted
successfully (ssh working, etc).
Comment 1 D Huen 2006-04-10 15:45:16 EDT
Created attachment 127569 [details]
Xorg.0.log when booting with kernel-2.6.16-1.2069_FC4 (fails)
Comment 2 D Huen 2006-04-10 15:47:07 EDT
Created attachment 127570 [details]
Log from a  successful boot (kernel-2.6.15-1.1833_FC4)
Comment 3 D Huen 2006-04-10 16:10:50 EDT
Sorry, forgot hardware configuration:-
AMD Athlon 64 2800+
Gigabyte K8VT800 Pro
Radeon 9800 Pro
Comment 4 D Huen 2006-04-22 08:58:32 EDT
Seems to be fixed in kernel-2.6.16-1.2096_FC4.

Note You need to log in before you can comment on or make changes to this bug.