Bug 18858 - sgml2latex doesn't look in the right directory
Summary: sgml2latex doesn't look in the right directory
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sgml-tools   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 19893 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-10 23:47 UTC by Kasper Ligaard Nielsen
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 10:46:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kasper Ligaard Nielsen 2000-10-10 23:47:24 UTC
While trying to convert a sgml (docbook) file to latex (or other formats
like html) the following occured:
---start---
[ligaard@ligaard ligaard]$ sgml2latex template.docbook
Processing file template.docbook
/usr/bin/nsgmls:<OSFD>0:1:57:W: cannot generate system identifier for
public text "-//OASIS//DTD DocBook V3.0//EN"
/usr/bin/nsgmls:<OSFD>0:1:57:E: reference to entity "ARTICLE" for which no
system identifier could be generated
/usr/bin/nsgmls:<OSFD>0:1:0: entity was defined here
/usr/bin/nsgmls:<OSFD>0:1:57:E: DTD did not contain element declaration for
document type name
/usr/bin/nsgmls:<OSFD>0:2:11:E: element "ARTICLE" undefined
/usr/bin/nsgmls:<OSFD>0:3:23:E: element "ARTICLEINFO" undefined
/usr/bin/nsgmls:<OSFD>0:4:17:E: element "TITLE" undefined
/usr/bin/nsgmls:<OSFD>0:5:18:E: element "AUTHOR" undefined
/usr/bin/nsgmls:<OSFD>0:6:29:E: element "FIRSTNAME" undefined
/usr/bin/nsgmls:<OSFD>0:7:27:E: element "SURNAME" undefined
/usr/bin/nsgmls:<OSFD>0:10:9:E: element "SECT1" undefined
/usr/bin/nsgmls:<OSFD>0:11:17:E: element "TITLE" undefined
/usr/bin/nsgmls:<OSFD>0:12:8:E: element "PARA" undefined
/usr/bin/nsgmls:<OSFD>0:15:17:E: element "SECT2" undefined
/usr/bin/nsgmls:<OSFD>0:16:25:E: element "TITLE" undefined
/usr/bin/nsgmls:<OSFD>0:17:24:E: element "PARA" undefined
/usr/bin/nsgmls:<OSFD>0:21:17:E: element "SECT2" undefined
/usr/bin/nsgmls:<OSFD>0:22:17:E: element "TITLE" undefined
/usr/bin/nsgmls:<OSFD>0:23:24:E: element "PARA" undefined
/usr/bin/sgmlsasp: can't open
`/usr/lib/sgml-tools/dist/article/latex2e/mapping': No such file or
directory
This is TeX, Version 3.14159 (Web2C 7.3.1)
LaTeX2e <1999/12/01> patch level 1
Babel <v3.6Z> and hyphenation patterns for american, french, german,
ngerman, i
talian, nohyphenation, loaded.

(template.docbook.tex)
! Emergency stop.
<*> \nonstopmode\input{template.docbook.tex}
                                            
No pages of output.
Transcript written on template.docbook.log.
[ligaard@ligaard ligaard]$ 
---end----
In the top of the output it says it can't find the DTD, and since I'm a
newbie in sgml/docbook I don't know if it means anything to the error
below: "/usr/bin/sgmlsasp: can't open
`/usr/lib/sgml-tools/dist/article/latex2e/mapping': No such file or
directory"

I looked around a bit and found that the file resides in
"/usr/lib/sgml-tools/dist/sgmltool/latex2e/mapping" (this for sgml2latex -
other for sgml2html).

IN SUMMARY: I think there is a path issue to be solved.

Below follows the small file I was trying to work on (it is from ibm
developernetwork:
http://www-4.ibm.com/software/developer/library/l-docbk.html?dwzone=linux?open&l=335,t=gr,p=docbooks)
---file: template.docbook---START
<!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook V3.0//EN">
   <article>
           <articleinfo>
           <title>Sample DocBook Template</title>
           <author>
                   <firstname>firstname here</firstname>
                   <surname>lastname here</surname>
           </author>
           </articleinfo>
   <sect1>
           <title>Section 1 Title</title>
   <para>
   This is a paragraph.  
   </para>
           <sect2>
                   <title>Section 2 Title</title>
                   <para>
   This is another paragraph...
                   </para>
           </sect2>
           <sect2>
           <title>Section 2 pt. 2</title>
                   <para>
   Yet another paragraph...
                   </para>
           </sect2>
   </sect1>
   </article>
---file: template.docbook---END

Comment 1 Tim Waugh 2000-10-11 10:35:05 UTC
Changing component to sgml-tools, and summary to match.

Comment 2 Tim Waugh 2000-10-12 10:36:21 UTC
The sgml-tools actually only handle linuxdoc.  You can use openjade to process
DocBook documents.  See the db2* commands.

Admittedly, the man pages for sgml-tools don't say anything about this, and they
probably should.

Comment 3 Tim Waugh 2002-01-10 10:46:53 UTC
The package is now called 'linuxdoc-tools'.


Comment 4 Tim Waugh 2002-01-10 10:47:52 UTC
*** Bug 19893 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.