Bug 19893 - sgml-tools-1.0.9-8 seems unaware of the catalog or dtd files provided by docbook-3.1-7/sgml-common
sgml-tools-1.0.9-8 seems unaware of the catalog or dtd files provided by docb...
Status: CLOSED DUPLICATE of bug 18858
Product: Red Hat Linux
Classification: Retired
Component: sgml-tools (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-26 22:06 EDT by Alaeddin A. Aydiner
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 05:47:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alaeddin A. Aydiner 2000-10-26 22:06:33 EDT
[It would be nice to provide a more recent docbook as a package
enhancement too.]

By unaware, I mean that sgmlcheck, sgml2x do not seem to know that
the sgml library is in /usr/lib/sgml. Indeed, sgmltools have their
own dtd directory, /usr/lib/sgml-tools/dtd.

I suspect at Redhat people do not use these particular versions of
docbook, sgml-common and sgml-tools. If so, it would be nice to
provide those working versions.

To reproduce the problem (or prove me wrong:-), just try
sgmlcheck docbooksgmlfile
Thanks.
Comment 1 Tim Waugh 2000-10-27 10:13:06 EDT
sgml-tools only works for LinuxDoc and HTML I'm afraid.

You can use openjade and programs like 'db2html' (from the stylesheets package)
to process DocBook documents.

The documentation probably needs updating to say something to that effect..
Comment 2 Tim Waugh 2002-01-10 05:47:57 EST

*** This bug has been marked as a duplicate of 18858 ***

Note You need to log in before you can comment on or make changes to this bug.