Bug 188581 - module manger not working due to libglade bug
module manger not working due to libglade bug
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnomesword (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael A. Peters
Fedora Extras Quality Assurance
:
: 187198 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 10:19 EDT by Christoph Wickert
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-17 11:26:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 328443 None None None Never

  None (edit)
Description Christoph Wickert 2006-04-11 10:19:09 EDT
Description of problem:
The module manager doesn't work because of a libglade bug. Signal handlers are
not found.

Version-Release number of selected component (if applicable):
gnomesword-2.1.5-2.fc5

How reproducible:
every time

Steps to Reproduce:
1. install gnomesword on Core 5 or rawhide
2. start gnomesword
> # gnomesword2
>
> Initiating GNOME session handler
> 
> 
> (gnomesword2:14900): GnomeUI-WARNING **: gnome_app_remove_menus: couldn't find
first item to remove!
> 

3. select "Edit" -> "Module Manger"
>
> ** Message: /usr/share/gnomesword/module-manager.glade
> 
> ** (gnomesword2:14900): WARNING **: callback function not found:
on_radiobutton2_toggled
>
>** (gnomesword2:14900): WARNING **: callback function not found:
on_mod_mgr_response
>
>** (gnomesword2:14900): WARNING **: callback function not found: on_dialog_destroy
>
>** (gnomesword2:14900): WARNING **: callback function not found:
on_treeview1_button_release_event
>
>** (gnomesword2:14900): WARNING **: callback function not found:
on_notebook1_switch_page
>
>** (gnomesword2:14900): WARNING **: callback function not found: on_button6_clicked
>
>** (gnomesword2:14900): WARNING **: callback function not found: on_button5_clicked
>
>** (gnomesword2:14900): WARNING **: callback function not found: on_button8_clicked
>
>** (gnomesword2:14900): WARNING **: callback function not found: on_button7_clicked
>/usr/share/sword/ is write protected
 
Actual results:
Module Manager doesn't work.

Additional info:
This is the famous libglade bug, see
http://bugzilla.gnome.org/show_bug.cgi?id=328443
or
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=184001
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=187623

Add something like

> %if "%fedora" > "4"
> export LDFLAGS="${LDFLAGS} -Wl,--export-dynamic"
> %endif

before %configure as workaround.
Comment 1 Michael A. Peters 2006-04-17 09:43:11 EDT
*** Bug 187198 has been marked as a duplicate of this bug. ***
Comment 2 Michael A. Peters 2006-04-17 11:26:03 EDT
Gnomesword is behaving a lot better now.
Thanks for the tip.

Through build system, just waiting to be signed/pushed.

Note You need to log in before you can comment on or make changes to this bug.