Bug 188584 - some pdf files are marked as text/plain
some pdf files are marked as text/plain
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shared-mime-info (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 10:40 EDT by Jiri Cerny
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 16:53:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 6577 None None None Never

  None (edit)
Description Jiri Cerny 2006-04-11 10:40:44 EDT
Description of problem:

On FC5 system with all recent updates some pdf files are given mime type
text/plain (as seen eg. in file properties in Nautilus). From observation, this
problem appears only for PDF files that contain a lot of  ASCII characters at
the begining of the file. It has then influence on the right-click-menu entries,
  and on applications offered to open the file. 


Version-Release number of selected component (if applicable):
shared-mime-info-0.17-1.fc5.1
gnome-vfs2-2.14.0-2

How reproducible:
1. Save e.g. file at http://ima.epfl.ch/~cerny/bad.pdf on local disk.
2. In nautilus right click on it -> properties 
type is Plain text document (modulo translation error from czech)

I can attach the file if necessary, but it is rather big.   

Expected results:
Type is application/pdf
Comment 1 Joachim Frieben 2006-04-12 16:54:54 EDT
Right, this issue has been around for a couple of weeks now, also
on a current "rawhide" system ("shared-mime-info-0.17-2").
Occurs most of the time when a PDF file is opened from within a
web browser ("epiphany" in my case). Once the file is saved to disk,
it can be opened without problem, e.g. with "evince foo.pdf".
Comment 2 Alex Lancaster 2006-06-23 04:00:24 EDT
Seems to be caused by this upstream bug: 

https://bugs.freedesktop.org/show_bug.cgi?id=6577

upping the priority of application/pdf to 60 in the /usr/share/mime/magic  fixed
this for me.  This is probably a dupe of bug #193582.
Comment 3 Joachim Frieben 2006-06-23 08:04:02 EDT
I had posted a related report for the development tree, see Bug #190858.
The issue is also solved by upgrading "shared-mime-info" to current "CVS",
as I had pointed out in:

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=190858#c6
Comment 4 Alex Lancaster 2006-06-29 11:56:24 EDT
Can this be closed as a duplicate of bug #193582?  shared-mime-info-0.17-1.fc5.2
has been pushed for fc5 which fixes this.
Comment 5 Joachim Frieben 2006-06-29 13:21:40 EDT
This report should be closed as solved in "ERRATA". The Fedora development
tree still has only the broken package.

Note You need to log in before you can comment on or make changes to this bug.