Bug 190858 - shared-mime-info prevents evince from opening online PDF files
shared-mime-info prevents evince from opening online PDF files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shared-mime-info (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
: 196351 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 15:04 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 16:59:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 6577 None None None Never

  None (edit)
Description Joachim Frieben 2006-05-05 15:04:17 EDT
Description of problem:
When "mozplugger" is installed, PDF files that are on the web cannot
be opened by "epiphany" or "firefox". 

Version-Release number of selected component (if applicable):
mozplugger-1.7.3-2.2.1

How reproducible:
Always.

Steps to Reproduce:
1. Point the browser to a PDF file on the web.
  
Actual results:
A pop-up window appears claiming
 "Mozplugger error on opening PDF file:
  Unable to open document
  Unhandled MIME type: 'application/octet-stream'".
The main window remains blank.

Expected results:
The document should be displayed embedded in the browser window.

Additional info:
When "mozplugger" is not installed, then "evince" is used as an
external helper application and renders the file without problem.
Even when "mozplugger" is installed, everything is fine as long
as you open a local (!) file. It is then displayed correctly inside
the browser window.
Comment 1 David Juran 2006-05-13 18:29:32 EDT
I believe this really is a evince problem. Sounds a lot like
http://bugzilla.gnome.org/show_bug.cgi?id=336448
Comment 2 Joachim Frieben 2006-05-15 14:31:28 EDT
Yes, that's correct. I have rebuilt and installed "mozplugger-1.7.3-1"
on a system that runs FC4, and it correctly embeds PDF files into the
browser window. Installed viewer is "evince-0.4.0-1.2".
Comment 3 Joachim Frieben 2006-05-18 04:47:16 EDT
This should solve the problem:

>
> Evince   0.5.3
> ==============
>
> Bug Fixes: * Fixed mime type detection by file contents
>
Comment 4 Joachim Frieben 2006-05-18 06:30:39 EDT
Updated "evince-0.5.2-1" package to use version 0.5.3 ("poppler" update
from CVS also required). Unfortunately, the issue persists.
Comment 5 Joachim Frieben 2006-05-23 16:29:04 EDT
No improvement for updated packages "evince-0.5.3-1" and
"poppler-0.5.2-1".
Comment 6 Joachim Frieben 2006-05-25 06:07:19 EDT
The bug gets fixed by ugrading "shared-mime-info-0.17-2" to current CVS.
Please release updated package for rawhide and FC5 which is also
afflicted by this bug!
Comment 7 Peter Bieringer 2006-06-14 04:34:14 EDT
@Reporter & CCs, can you please re-submit all changes since friday? Bugzilla DB
had a failure :-(( I've already deleted my e-mails.
Comment 8 Alex Lancaster 2006-06-23 08:24:11 EDT
Seems like there are several dupes of this bug, notably bug #193582.  Also  bug
#186241 and bug #188584.  

Can somebody with sufficient bugzilla permissions mark them as duplicates,
please?  Also can somebody in Core please address this problem (applying the
patch from CVS as mentioned in comment #6) so we don't keep getting this bug
reported.
Comment 9 Alex Lancaster 2006-06-23 08:28:13 EDT
This is the relevant change that makes it work for me:

http://webcvs.freedesktop.org/mime/shared-mime-info/freedesktop.org.xml.in?r1=1.138&r2=1.139
Comment 10 Fedora Update System 2006-06-25 09:20:52 EDT
shared-mime-info-0.17-1.fc5.2 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 11 Alex Lancaster 2006-06-29 11:48:53 EDT
(In reply to comment #10)
> shared-mime-info-0.17-1.fc5.2 has been pushed for fc5, which should resolve
this issue.  If these problems are still present in this version, then please
make note of it in this bug report.

Works for me now.  Please do close.
Comment 12 Joachim Frieben 2006-06-29 13:24:36 EDT
No, this bug was posted for Fedora Core devel for which the available package is
still broken. Bug #188584 can be closed though because an errata package has
been released for FC5.
Comment 13 Kristian Høgsberg 2006-06-29 16:55:59 EDT
*** Bug 196351 has been marked as a duplicate of this bug. ***
Comment 14 Kristian Høgsberg 2006-06-29 16:59:13 EDT
The mime PDF fix from CVS has been added in rawhide and the rpm rebuilt. 
Closing bug.

Note You need to log in before you can comment on or make changes to this bug.