Bug 188594 - pnmtopng fails
pnmtopng fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
: 188755 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 12:20 EDT by Robin Humble
Modified: 2013-07-02 19:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 08:27:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Humble 2006-04-11 12:20:38 EDT
Description of problem:
pnmtopng dumps core and fails to work

Version-Release number of selected component (if applicable):
netpbm-10.33-0.FC4

How reproducible:
100%

Steps to Reproduce:
1. pngtopnm /usr/share/icons/Bluecurve/48x48/apps/redhat-system_settings.png |
pnmtopng > red.png

Actual results:
pnmtopng: nstring.c:940: vasprintfN: Assertion `str_l2 == str_l' failed.
Abort (core dumped)


Expected results:
producing an image

Additional info:
it works on some images. eg.
  ppmmake red 10 10 > red.ppm
  pnmtopng < red.ppm > red.png
but doing the same thing in one line does not work (hits the same assert() as
above):
  ppmmake red 10 10 | pnmtopng > red.png

as another example, this works
  pngtopnm /usr/share/icons/Bluecurve/48x48/apps/redhat-system_settings.png |
pnmquant 256 > red.ppm
  pnmtopng < red.ppm > red.png
but without the pnmquant it does not work (same assert again):
  pngtopnm /usr/share/icons/Bluecurve/48x48/apps/redhat-system_settings.png >
red.ppm
  pnmtopng < red.ppm > red.png
Comment 1 Jindrich Novy 2006-04-13 10:41:04 EDT
Ok, pnmtopng will fail with the error even if it's called with no arguments on
x86_64. The error doesn't occur on 32bit arches. The culprit is the code in
nstring.h, which is now fixed in rawhide.
Comment 2 Jindrich Novy 2006-04-14 14:06:54 EDT
*** Bug 188755 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2006-04-17 11:41:51 EDT
netpbm-10.33-1.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Robin Humble 2006-04-17 13:14:04 EDT
looks resolved to me. speedy work. thanks!
Comment 5 Jindrich Novy 2006-04-18 08:27:46 EDT
Thanks for feedback, closing ERRATA then.

Note You need to log in before you can comment on or make changes to this bug.