Bug 188755 - LaTeX2HTML image toolchain breaks on PPC
LaTeX2HTML image toolchain breaks on PPC
Status: CLOSED DUPLICATE of bug 188594
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 16:14 EDT by oliver
Modified: 2013-07-02 19:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-14 14:06:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description oliver 2006-04-12 16:14:28 EDT
Description of problem:
On the PPC platform, LaTeX2HTML does not generate included images (e.g. for
mathematical expressions), as the image processing toolchain breaks.  The main
bug appears to be in /usr/bin/pnmcolormap, which is called from the
/usr/bin/pstoimg script.  In addition, /usr/bin/pnmtopng segfaults on empty
input.  This is a secondary bug triggered by the first.

Version-Release number of selected component (if applicable):
latex2html-2002.2.1-3

How reproducible:
Always.

Steps to Reproduce:
Overall bug: Run latex2html on any file containing math and/or images.  Result:
math/images will not show in the generated HTML.

Bug in /usr/bin/pnmcolormap: Is exposed by running 
  $ pnmcolormap 256 -verbose /tmp/p3203.pnm
  pnmcolormap: making histogram...
  pnmcolormap: Scanning image 0
  pnmcolormap: 2 colors so far
  pnmcolormap: Scanning image 1
  pnmcolormap: Image 1 maxval (1) is not the same as Image 0 (255)
Where /tmp/p3203.pnm is one of the intermediary file generated by latex2html.  

Secondary bug in /usr/bin/pnmtopng:
  $ /usr/bin/pnmtopng < /dev/zero 
  Segmentation fault

Actual results:
see above

Expected results:
Same commands on an i386 system (this is Suse 9.0, as I currently don't have
access to a fedora i386 machine):

> pnmcolormap 256 -verbose /tmp/p10758.pnm
pnmcolormap: making histogram...
pnmcolormap: 2 colors found
pnmcolormap: Image already has few enough colors (<=256).  Keeping same colors.
pnmcolormap: Generating 2 x 1 image
P5
2 1
255

> /usr/bin/pnmtopng < /dev/zero
[hangs]

Additional info:
Comment 1 Jindrich Novy 2006-04-14 07:52:52 EDT
Netpbm is at fault here, so changing the component. I fixed the latest pnmtopng
in netpbm-10.33 what caused some problems. Which netpbm do you use? Could you
please test it with the latest rawhide netpbm (10.33-2)? I tried that and
latex2html works for me with a sample tex file with included image. I release FC
updates when the fix is confirmed.
Comment 2 oliver 2006-04-14 11:42:08 EDT
I was using netpbm-10.33 on a fully up-to-date fc4.  The binary netpbm from
rawhide does not install on fc4, so compiled the source RPM.  Lot's of compiler
warnings, looks scary...  In any case, my LaTeX2HTML runs now work for me - thanks!
Comment 3 Jindrich Novy 2006-04-14 14:06:41 EDT
Yes, the warnings need some upstream care to not to look that scary ;) Many of
them might be a source of another bugs caused mostly by usage of uninitialized
variables.

*** This bug has been marked as a duplicate of 188594 ***

Note You need to log in before you can comment on or make changes to this bug.