Bug 1885941 - [release 4.6] Collect ServiceAccount statistics
Summary: [release 4.6] Collect ServiceAccount statistics
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Insights Operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.6.z
Assignee: Ricardo Lüders
QA Contact: Pavel Šimovec
URL:
Whiteboard:
: 1885935 (view as bug list)
Depends On: 1885930
Blocks: 1885936 1885937
TreeView+ depends on / blocked
 
Reported: 2020-10-07 10:23 UTC by OpenShift BugZilla Robot
Modified: 2021-03-09 20:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Implements the Service Account Gatherer to the Insights Operator to collect field managementState of Openshift Operators. Reason: If the lib-bucket-provisioner service account missing then the creation of lib-bucket-provisioner InstallPlan is overloading the etcd and impacting the performance of the OCP cluster. Therefore we need access to this data. Result: Data is being collected, anonymized, and stored at the Insights Operator archive report.
Clone Of:
Environment:
Last Closed: 2021-03-09 20:16:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift insights-operator pull 330 0 None open [release-4.6] Bug 1885941: Gather ServiceAccounts stats from cluster namespaces 2021-02-01 15:28:58 UTC
Red Hat Product Errata RHBA-2021:0674 0 None None None 2021-03-09 20:16:26 UTC

Description OpenShift BugZilla Robot 2020-10-07 10:23:03 UTC
+++ This bug was initially created as a clone of Bug #1885930 +++

This is adding collection of ServiceAccounts statistics from Openshift namespaces

Comment 2 Martin Kunc 2020-10-08 04:08:22 UTC
*** Bug 1885935 has been marked as a duplicate of this bug. ***

Comment 4 Scott Dodson 2020-12-09 16:40:37 UTC
OCP Pillar leads have agreed that items which add new capabilities are not eligible for high severity so I'm lowering this to medium so that we may better prioritize the queue.

Comment 6 Pavel Šimovec 2021-02-25 14:29:49 UTC
=== RUN   TestArchiveContains/ServiceAccounts
    main_test.go:375: 1 service accounts file matches pattern `^config/serviceaccounts\.json$`
    --- PASS: TestArchiveContains/ServiceAccounts (0.00s)

verified on https://github.com/openshift/insights-operator/commit/25157502e9c650959e6545cf1a7ce16654a3ded5

Comment 9 errata-xmlrpc 2021-03-09 20:16:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.20 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0674


Note You need to log in before you can comment on or make changes to this bug.