Bug 188636 - Wine/DVDShrink can't find gnome-mount DVD
Wine/DVDShrink can't find gnome-mount DVD
Status: CLOSED DUPLICATE of bug 183735
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
Depends On:
  Show dependency treegraph
Reported: 2006-04-11 18:44 EDT by Jay Cliburn
Modified: 2013-03-13 00:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-17 18:02:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jay Cliburn 2006-04-11 18:44:39 EDT
Description of problem:
A movie DVD mounted by gnome-mount can't be detected by DVD Shrink under Wine. 
I created an fdi file that overrides the HAL default volume.name with the string
"cdrecorder" so that DVDs are always mounted at /media/cdrecorder instead of

[jcliburn@osprey ~]$ cat /usr/share/hal/fdi/policy/95userpolicy/optical.fdi
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
    <match key="block.device" string="/dev/hdc">
      <match key="@block.storage_device:storage.model" string="_NEC DVD_RW
        <merge key="volume.label" type="string">cdrecorder</merge>

I then configured Wine to map drive D:\ to /media/cdrecorder.
[jcliburn@osprey ~]$ ls -l .wine/dosdevices/
total 12
lrwxrwxrwx 1 jcliburn jcliburn 10 Apr 11 17:25 c: -> ../drive_c
lrwxrwxrwx 1 jcliburn jcliburn 18 Apr 11 17:29 d: -> /media/cdrecorder/
lrwxrwxrwx 1 jcliburn jcliburn  1 Apr 11 17:25 z: -> /

When I insert a movie into the DVD drive (NEC ND-3520A), start DVD Shrink, and
click "Open Disc", the following error popup is presented.

DVD Shrink encountered an error and cannot continue.
Failed to open file "\\. \d:"
File not found

If I create a mount point (an empty directory) at /media/cdrecorder, add this
entry to /etc/fstab,

/dev/hdc    /media/cdrecorder    udf,iso9660    user,exec,noauto 0 0

and manually mount the DVD drive, then DVD Shrink finds the drive and works
without error.

Version-Release number of selected component (if applicable):
DVD Shrink 3.2
gnome-mount 0.4

How reproducible:

Steps to Reproduce:
1.  Add a HAL rule to make DVDs mount at /media/cdrecorder
2.  Run winecfg and map a drive to /media/cdrecorder
3.  Run DVD Shrink under Wine and click "Open Disc"
Actual results:
DVD Shrink encountered an error and cannot continue.
Failed to open file "\\. \d:"
File not found

Expected results:
DVD opens without error.

Additional info:
Comment 1 George Billios 2006-04-14 10:23:32 EDT
This bug depends on this one:


Hello, Fedora devs????????? Anyone there??
Comment 2 John (J5) Palmieri 2006-04-17 18:02:02 EDT
I was on vacation for the last two weeks. Sorry if I was unable to get to your
issue in a timely manner.

*** This bug has been marked as a duplicate of 183735 ***

Note You need to log in before you can comment on or make changes to this bug.