Bug 183735 - dynamic mounting of cd-drives breaks wines cd detection
dynamic mounting of cd-drives breaks wines cd detection
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
: 188221 188636 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 02:28 EST by Andreas Bierfert
Modified: 2013-03-13 00:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-17 17:33:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
config fdi to get hal to mount cdrom in /media/cdrecord (527 bytes, text/plain)
2006-03-19 03:03 EST, Knut J BJuland
no flags Details

  None (edit)
Description Andreas Bierfert 2006-03-03 02:28:41 EST
Since cddrives are no longer in fstab and the drives name is used dynamically
for the mountpoint wine is not able to detect cddrives anymore correctly...
Comment 1 Knut J BJuland 2006-03-19 03:03:07 EST
Created attachment 126321 [details]
config fdi to get hal to mount cdrom in /media/cdrecord

This is my fdi files
Comment 2 Knut J BJuland 2006-03-19 03:04:26 EST
Comment on attachment 126321 [details]
config fdi to get hal to mount cdrom in /media/cdrecord

I am unable to get hal to mount in /media/cdrecord by using this files to
bypass normal behavoiur.
Comment 3 Andreas Bierfert 2006-04-07 02:45:59 EDT
*** Bug 188221 has been marked as a duplicate of this bug. ***
Comment 4 John (J5) Palmieri 2006-04-17 17:33:22 EDT
http://lists.freedesktop.org/archives/hal/2006-April/004936.html

Hal's drive policy keys are no longer used.  There is no way to change the mount
point as of yet with the new system but that is besides the point.

Wine needs to be fixed to deal with modern dynamic systems. Please file a bug
against Wine upstream. 
Comment 5 Andreas Bierfert 2006-04-17 17:51:23 EDT
Already did: http://bugs.winehq.org/show_bug.cgi?id=4694
Comment 6 John (J5) Palmieri 2006-04-17 18:02:16 EDT
*** Bug 188636 has been marked as a duplicate of this bug. ***
Comment 7 n0dalus 2006-07-31 04:06:49 EDT
I think this bug should really be reopened.

HALs functionality here violates the FHS (Filesystem Hierarchy Standard), so the
bug is in it -- not wine.

http://www.pathname.com/fhs/pub/fhs-2.3.html#MEDIAMOUNTPOINT

Please note the section in question is not marked as optional.

"The following directories, or symbolic links to directories, must be in /media,
if the corresponding subsystem is installed

Directory	Description
floppy	Floppy drive (optional)
cdrom	CD-ROM drive (optional)
cdrecorder	CD writer (optional)
zip	Zip drive (optional)"

In this case, cdrom is installed and as such there must be a directory or
symlink provided in /media/cdrom. There is nothing wrong with HAL mounting the
device at /media/VOLUME_NAME, but it needs to place a symlink in /media/cdrom so
applications following the FHS work without problems.
Comment 8 John (J5) Palmieri 2006-07-31 11:02:19 EDT
Notice the optional keyword I don't see the words must.  It is a shame for any
spec to have optional components but there you have it.  Please ask upstream if
they would implement the above. I personally think it is a bad idea since it
makes sure application writters don't move to a more robust system in the future
if they can rely on legacy hacks.  Besides I think wine already fixed the issue.
 In any case in FC-6 you will be able to change the mount directory manually via
the properties tab in nautilus.
Comment 9 n0dalus 2006-07-31 18:59:49 EDT
The word 'optional' next to the devices simply means the device is optional. If
you read it again you will note it says "_must_ be in /media, _if_ the
corresponding subsystem is installed". The section itself is not optional (or it
would have 'optional' in the title of the section).

The right way to push a new method of doing things is with a spec on
freedesktop.org or similar, not by breaking another spec and hoping people work
out on their own that HAL is the 'right' way to do it.

Wine is not the only application that needs a mountpoint to stay the same --
there are several native installers which use multiple-cds and require the same
mount point for each.

Currently the bug is still open in wine, btw:
http://bugs.winehq.org/show_bug.cgi?id=4694
Comment 10 Andreas Bierfert 2006-08-03 03:01:33 EDT
Actually I just forgot to close the wine bug. Wine works perfectly with hal now
so  this bug here should be closed and the discussion on how /media should be
handelt should move to a new bug.
Comment 11 John (J5) Palmieri 2006-08-03 10:13:25 EDT
Case in point of why I hate doing legacy shims such as /media/cdrom. It's so
2004 :-)  and if you don't do it apps move quicker to adapt to the better way of
doing things.  In any case it is not my call to make in the end so if someone
wants to see the FHS recomendation followed above I suggest opening a bug in
upstream HAL.  Staying closed.

Note You need to log in before you can comment on or make changes to this bug.