Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1886620 - Application behind service load balancer with PDB is not disrupted
Summary: Application behind service load balancer with PDB is not disrupted
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.7
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.7.0
Assignee: Antonio Ojea
QA Contact: zhaozhanqi
URL:
Whiteboard: SDN-CI-IMPACT
: 1868490 1890011 (view as bug list)
Depends On:
Blocks: 1868489 1868490 1868792 1891711
TreeView+ depends on / blocked
 
Reported: 2020-10-08 22:42 UTC by Benjamin Gilbert
Modified: 2021-01-13 15:23 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1828858
Environment:
Application behind service load balancer with PDB is not disrupted
Last Closed: 2021-01-13 15:23:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25606 0 None closed Bug 1886620: deflake e2e test "Application behind service load balancer with PDB is not disrupted " 2021-02-10 13:03:39 UTC

Comment 4 Andrew McDermott 2020-10-21 10:22:49 UTC
*** Bug 1890011 has been marked as a duplicate of this bug. ***

Comment 7 Ben Bennett 2020-10-27 14:19:06 UTC
*** Bug 1868490 has been marked as a duplicate of this bug. ***

Comment 9 zhaozhanqi 2020-11-09 03:09:57 UTC
Hi, Antonio
I just checked the scenario [sig-network-edge] Application behind service load balancer with PDB is not disrupted still in flaky list in the following 4.6 to 4.7 upgrade testing, As my understanding, it should be in pass list if this fixed.  please correct me if I'm wrong, thanks.

https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/release-openshift-origin-installer-e2e-gcp-upgrade-4.6-stable-to-4.7-ci/1325382252095344640

Comment 10 Antonio Ojea 2020-11-09 08:04:27 UTC
That failure mentioned there should be a pass

> Service was unreachable during disruption for at least 4s of 50m15s (0%), this is currently sufficient to pass the test/job but not considered completely correct:

As I commented in https://bugzilla.redhat.com/show_bug.cgi?id=1886620#c2, one of the probes has a minimal disruption (the one that create a new connection per each probe) and this must be related to something environmental, because the other probe (the on that does not create newer connections) never fails, that means that connectivity is ok

Comment 11 zhaozhanqi 2020-11-09 09:45:35 UTC
@Antonio Ojea thanks the explanation.

Comment 13 Antonio Ojea 2021-01-13 15:23:26 UTC
This doesn´t target a public release, is a test only fix


Closing per https://source.redhat.com/groups/public/atomicopenshift/atomicopenshift_wiki/openshift_container_platform_bug_owner_responsibilities

Else: AFTER the bug is VERIFIED by QA and only if the bug does not affect a publicly released version of the product it should simply be marked "CLOSED / CURRENTRELEASE"


Note You need to log in before you can comment on or make changes to this bug.