Bug 188700 - no way to specify proxy
no way to specify proxy
Status: CLOSED DUPLICATE of bug 185309
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
: 188699 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 08:10 EDT by V V Raja Rao
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-17 18:23:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description V V Raja Rao 2006-04-12 08:10:37 EDT
Description of problem:
There seems to be no way to tell pup to go through a proxy. I tried setting
the env var http_proxy and also setting the Network Proxy from the menu. But
still pup does not seem to pick the proxy



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Open pup on a m/c which connects to internet through a proxy
2.
3.
  
Actual results:
pup hangs for sometime and displays an error message that it couldn't connect

Expected results:
pup should display the package information 

Additional info:
Comment 1 Jeremy Katz 2006-04-12 14:18:20 EDT
Can you grab http://people.redhat.com/~katzj/yum-2.6.0-2.noarch.rpm and see if
it helps?

You may need to set the proxy in /etc/yum.conf also.
Comment 2 Jeremy Katz 2006-04-12 14:18:55 EDT
*** Bug 188699 has been marked as a duplicate of this bug. ***
Comment 3 V V Raja Rao 2006-04-13 00:11:44 EDT
I tried with http://people.redhat.com/~katzj/yum-2.6.0-2.noarch.rpm  and also
set the proxy in /etc/yum.conf as given in the docs. But still the same problem.
Doing a netstat shows that pirut/pup is directly trying to access redhat.com.
Comment 4 Jeremy Katz 2006-04-17 18:23:12 EDT
Aha, I see what's going on.  Marking a dupe of the main bug I'm going to use for
tracking this so that I don't have to juggle a few of these

*** This bug has been marked as a duplicate of 185309 ***
Comment 5 David Lawrence 2006-06-27 21:42:39 EDT
Moving component to pirut. Sorry for the spam.

Note You need to log in before you can comment on or make changes to this bug.