Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1887354 - RBAC refuses requests at times – was: openshift-state-metrics/kube-state-metrics degraded for a few minutes
Summary: RBAC refuses requests at times – was: openshift-state-metrics/kube-state-metr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.z
Assignee: Pawel Krupa
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1880646 1889111 1889881 1891079 1957051 (view as bug list)
Depends On: 1863011 1879019 1879159 1887339
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-12 08:28 UTC by Pawel Krupa
Modified: 2021-05-06 10:57 UTC (History)
32 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1863011
Environment:
[sig-instrumentation] Prometheus when installed on the cluster should have important platform topology
Last Closed: 2020-11-17 16:06:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 956 0 None closed Bug 1887354: Backport fix checking if ClusterRoleBindings need update 2021-02-07 09:07:18 UTC
Red Hat Knowledge Base (Solution) 5582161 0 None None None 2020-11-18 08:14:35 UTC
Red Hat Product Errata RHBA-2020:5051 0 None None None 2020-11-17 16:06:29 UTC

Comment 1 Sergiusz Urbaniak 2020-10-21 08:23:33 UTC
*** Bug 1889881 has been marked as a duplicate of this bug. ***

Comment 2 Simon Pasquier 2020-10-21 14:02:27 UTC
*** Bug 1889111 has been marked as a duplicate of this bug. ***

Comment 3 Simon Pasquier 2020-10-22 13:41:05 UTC
*** Bug 1880646 has been marked as a duplicate of this bug. ***

Comment 5 Sergiusz Urbaniak 2020-10-26 07:23:22 UTC
*** Bug 1891079 has been marked as a duplicate of this bug. ***

Comment 6 Scott Dodson 2020-10-28 15:31:31 UTC
I've added bug 1887339 to the dependencies here because the PR tied to that bug is listed as being included in the PR for this bug, that means that this bug fix won't land until 1887339 has been VERIFIED. If that's not correct please correct me.

Comment 11 Junqi Zhao 2020-11-10 03:19:10 UTC
upgrade from 4.5.0-0.nightly-2020-11-06-162615 to 4.5.0-0.nightly-2020-11-07-002125, monitoring components were not degraded during the upgrade progress

Comment 14 errata-xmlrpc 2020-11-17 16:06:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.19 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5051

Comment 16 Jan Fajerski 2021-05-06 10:57:15 UTC
*** Bug 1957051 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.