Bug 1889881 - [sig-instrumentation][sig-builds][Feature:Builds] Prometheus when installed on the cluster should start and expose a secured proxy and verify build metrics
Summary: [sig-instrumentation][sig-builds][Feature:Builds] Prometheus when installed o...
Keywords:
Status: CLOSED DUPLICATE of bug 1887354
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Sergiusz Urbaniak
QA Contact: Junqi Zhao
URL:
Whiteboard: buildcop
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-20 19:16 UTC by Andrew Stoycos
Modified: 2020-10-21 08:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
[sig-instrumentation][sig-builds][Feature:Builds] Prometheus when installed on the cluster should start and expose a secured proxy and verify build metrics
Last Closed: 2020-10-21 08:23:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Andrew Stoycos 2020-10-20 19:16:09 UTC
test:
[sig-instrumentation][sig-builds][Feature:Builds] Prometheus when installed on the cluster should start and expose a secured proxy and verify build metrics 

is failing frequently in CI, see search results:
https://search.ci.openshift.org/?maxAge=168h&context=1&type=bug%2Bjunit&name=&maxMatches=5&maxBytes=20971520&groupBy=job&search=%5C%5Bsig-instrumentation%5C%5D%5C%5Bsig-builds%5C%5D%5C%5BFeature%3ABuilds%5C%5D+Prometheus+when+installed+on+the+cluster+should+start+and+expose+a+secured+proxy+and+verify+build+metrics


https://prow.ci.openshift.org/job-history/origin-ci-test/pr-logs/directory/pull-ci-openshift-cluster-network-operator-release-4.5-e2e-ovn-hybrid-step-registry


`fail [github.com/openshift/origin/test/extended/util/prometheus/helpers.go:174]: Expected
    <map[string]error | len:1>: {
        "openshift_build_total{phase=\"Complete\"} >= 0": {
            s: "promQL query: openshift_build_total{phase=\"Complete\"} >= 0 had reported incorrect results:\n[]",
        },
    }
to be empty`

I'm Seeing Prometheus errors across 4.5 CI, https://sippy.ci.openshift.org/?release=4.5#TopFailingTestsWithoutABug, all down from high passing rates in prior weeks

Comment 2 Sergiusz Urbaniak 2020-10-21 08:23:46 UTC

*** This bug has been marked as a duplicate of bug 1887354 ***


Note You need to log in before you can comment on or make changes to this bug.