Bug 188941 - wxPythonGTK2 breaks due to undefined symbol in wxGTK2 library
wxPythonGTK2 breaks due to undefined symbol in wxGTK2 library
Status: CLOSED DUPLICATE of bug 185777
Product: Fedora
Classification: Fedora
Component: compat-wxGTK (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-13 16:19 EDT by Ade Rixon
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 18:08:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ade Rixon 2006-04-13 16:19:17 EDT
Description of problem:
(Note: this bug is actually for compat-wxGTK2, but that package name isn't
listed in Bugzilla.)
When I install and run the tovid GUI from the RPMs provided on the tovid home
page, I get a library error with wxPython.

Version-Release number of selected component (if applicable):
2.4.2-17.fc5

How reproducible:
Always.

Steps to Reproduce:
1.Download and install tovid 0.25 RPMs from http://tovid.berlios.de/
2.Install dependencies from Extras (wxPython, etc.)
3.Run tovidgui.
4.Alternatively, simply run the following Python script:
#!/usr/bin/python
import wx
  
Actual results:
> tovidgui 
Traceback (most recent call last):
  File "/usr/bin/tovidgui", line 20, in ?
    import wx
  File "/usr/lib/python2.4/site-packages/wx/__init__.py", line 45, in ?
    from wxPython import wx
  File "/usr/lib/python2.4/site-packages/wxPython/__init__.py", line 20, in ?
    import wxc
ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol: pango_x_get_context

Expected results:
tovidgui appears.

Additional info:
This symbol appears to be obsolete since Pango 1.10. The version in FC5 is 1.12.
What version was this library built against?
I have the following packages installed:
compat-wxGTK2-2.4.2-17.fc5
compat-wxGTK2-gl-2.4.2-17.fc5
compat-wxGTK-common-2.4.2-17.fc5
wxGTK-2.6.2-5.fc5
wxGTK-gl-2.6.2-5.fc5
wxPythonGTK2-2.4.2.4-7
(wxPythonGTK2 depends on compat-wxGTK2.)
Comment 1 Andrew 2006-08-16 16:23:30 EDT
Looks like a duplicate of issue 185777
Comment 2 Fabrice Bellet 2006-08-30 07:52:34 EDT
Would it be possible to apply this patch
(http://svn.exactcode.de/t2/trunk/package/x11/wxwidgets24/pango.patch) to solve
this issue ?
Comment 3 Tom "spot" Callaway 2006-09-11 18:08:24 EDT

*** This bug has been marked as a duplicate of 185777 ***

Note You need to log in before you can comment on or make changes to this bug.