This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 185777 - (wxBroken) Importing wx fails with compat-wxPythonGTK2
Importing wx fails with compat-wxPythonGTK2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compat-wxPythonGTK2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 186790 187593 188215 188941 (view as bug list)
Depends On:
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-03-17 16:28 EST by Scott Tsai
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 19:20:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2006-03-17 16:28:07 EST
Description of problem:
Importing the wx package fails

Version-Release number of selected component (if applicable):
wxPythonGTK2-2.4.2.4-7
gtk2-2.8.15-1

How reproducible:
always

Steps to Reproduce:
1. python -c 'import wx'
  
Actual results:
Traceback (most recent call last):
  File "<string>", line 1, in ?
  File "/usr/lib64/python2.4/site-packages/wx/__init__.py", line 45, in ?
    from wxPython import wx
  File "/usr/lib64/python2.4/site-packages/wxPython/__init__.py", line 20, in ?
    import wxc
ImportError: /usr/lib64/libwx_gtk2-2.4.so.0: undefined symbol: pango_x_get_context


Expected results:
(no output)

Additional info:
My guess it that since gtk-2.8's "pkg-config gtk+-2.0 --libs" now links to
"-lpangocairo-1.0" instead of "-lpangox-1.0", wx will need to be built using 
"pkg-config gtk+-x11-2.0" instead.
Comment 1 Matthew Miller 2006-03-17 16:32:33 EST
Thanks. This will be fixed with the update for bug 163440, when wxPython 2.6.3.0
comes out any day now. I'm sorry for such a delay -- I expected that to be any
day now last month. But it really looks like any day now at this point, for real.
Comment 2 Marc Wiriadisastra 2006-03-23 03:45:51 EST
It seems to be doing this in x86 as well. 

[root@localhost rufus-0.6.0]# python
Python 2.4.2 (#1, Feb 12 2006, 03:59:46)
[GCC 4.1.0 20060210 (Red Hat 4.1.0-0.24)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import wx
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib/python2.4/site-packages/wx/__init__.py", line 45, in ?
    from wxPython import wx
  File "/usr/lib/python2.4/site-packages/wxPython/__init__.py", line 20, in ?
    import wxc
ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol: pango_x_get_context

Not sure if I should open up another bug or file under here.
Comment 3 Matthew Miller 2006-03-26 10:31:07 EST
*** Bug 186790 has been marked as a duplicate of this bug. ***
Comment 4 Matthew Miller 2006-03-26 10:39:24 EST
(This is broken across the board, not just on x86_64.)

As noted above, this will be fixed for wxPython 2.6.x in, I hope, a matter of
days. (Still waiting on wxPython 2.6.3.0; wxGTK 2.3.0 is out now and the
wxPython author says he'll just need a day or two.)

This is an issue with the 2.4 wxPython, and so should be reassigned to the
"compat" package.
Comment 5 Matthew Miller 2006-04-01 11:07:47 EST
*** Bug 187593 has been marked as a duplicate of this bug. ***
Comment 6 Matthew Miller 2006-04-22 18:17:54 EDT
*** Bug 188215 has been marked as a duplicate of this bug. ***
Comment 7 Matthew Miller 2006-04-22 18:22:32 EDT
So, um, how is this *supposed* to work? 'Cause right now, if you install
compat-wxPythonGTK2 and the new wxPython 2.6.x package side-by-side, ALL
wxPython programs are broken -- you can't use the new package either. Case in point:

$ /usr/share/doc/wxPython-2.6.3.2/demo/demo.py
Traceback (most recent call last):
  File "/usr/share/doc/wxPython-2.6.3.2/demo/demo.py", line 3, in ?
    import Main
  File "/usr/share/doc/wxPython-2.6.3.2/demo/Main.py", line 32, in ?
    import wx                  # This module uses the new wx namespace
  File "/usr/lib/python2.4/site-packages/wx/__init__.py", line 45, in ?
    from wxPython import wx
  File "/usr/lib/python2.4/site-packages/wxPython/__init__.py", line 20, in ?
    import wxc
ImportError: /usr/lib/libwx_gtk2-2.4.so.0: undefined symbol: pango_x_get_context


But if I remove the compat-wxPythonGTK2, the new package works fine.
Comment 8 Matthew Miller 2006-04-22 18:27:34 EDT
Also, I want to add for the record that wxPython 2.4.x is unmaintained upstream.
There is a migration guide here: http://www.wxpython.org/migrationguide.php

My inclination is to remove the compat package from FE devel, although it will
still need to be maintained in FE4 & FE5. If this isn't reasonable for the FE6
timeframe, it should be revisited after that branches.
Comment 9 Joel Schaerer 2006-04-22 19:19:41 EDT
Any idea when this will be fixed? I need it soon, so if you don't have any plans
to fix it, i will try to install it myself.
Comment 10 Scott Tsai 2006-04-22 21:24:22 EDT
Since compat-wxPythonGTK2 and wxPython can't be installed side-by-side unlike
the old pygtk and pygtk2, I see no other way then to just add a conflict rule in
wxPython.

And compat-wxPythonGTK2 obviously needs patching and rebuilding to fix the
"pango_x_get_context" problem.
Comment 11 Matthew Miller 2006-04-22 21:40:35 EDT
Joel -- I don't have any plans to work on it, but Tom "spot" Callaway, the
maintainer of the compat-wx* packages, probably does.
Comment 12 Tom "spot" Callaway 2006-09-11 18:08:36 EDT
*** Bug 188941 has been marked as a duplicate of this bug. ***
Comment 13 Tom "spot" Callaway 2006-09-11 19:20:04 EDT
Alright. Sorry it took so long to tackle this.

Fixed with compat-wxGTK*-2.4.2-21 and compat-wxPython-2.4.2.4-12, built for
FC-4, FC-5, devel.

Note You need to log in before you can comment on or make changes to this bug.