Bug 188967 - Programs started from terminal appear beneath terminal window
Summary: Programs started from terminal appear beneath terminal window
Status: CLOSED DUPLICATE of bug 186308
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-13 23:30 UTC by Kyrre Ness Sjøbæk
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-13 23:48:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kyrre Ness Sjøbæk 2006-04-13 23:30:52 UTC
Description of problem:
Not exactly a bug, but a huge annoyance: If you start a (graphical) program from
gnome-terminal, it is assumed by metacity that gnome-terminal should retain
focus, and therefore the newly lauched program does not get focus, but appears
beneath my terminal. Inconvenient.

Version-Release number of selected component (if applicable):
gnome-terminal-2.14.0-1

How reproducible:
Every time

Steps to Reproduce:
1. Open gnome-terminal
2. Type a command that starts a graphical program you want to use (say,
"htmlview &")
3.Get annoyed by having to manualy change focus to the program you just started
  
Actual results:
Program does not get focus. Gnome-terminal keeps focus

Expected results:
Gnome-terminal looses focus. Program steals focus

Additional info:
I think this has something to do with the "focus stealer prevention" implemented
in fc5...

Comment 1 Ignacio Vazquez-Abrams 2006-04-13 23:48:53 UTC

*** This bug has been marked as a duplicate of 186308 ***


Note You need to log in before you can comment on or make changes to this bug.