Bug 1889678 - The "Should forward and receive packets" dpdk test always fails
Summary: The "Should forward and receive packets" dpdk test always fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: CNF Platform Validation
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.z
Assignee: Federico Paolinelli
QA Contact: Nikita
URL:
Whiteboard:
: 1889743 (view as bug list)
Depends On: 1889631 1889743
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-20 11:15 UTC by OpenShift BugZilla Robot
Modified: 2020-12-17 06:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-17 06:55:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:5187 0 None None None 2020-12-17 06:56:03 UTC

Comment 1 Sebastian Scheinkman 2020-10-20 17:02:29 UTC
*** Bug 1889743 has been marked as a duplicate of this bug. ***

Comment 10 elevin 2020-11-18 14:35:26 UTC
!Validated on Intel nic

Client Version: 4.6.4
Server Version: 4.6.4
Kubernetes Version: v1.19.0+9f84db3
Container: registry-proxy.engineering.redhat.com/rh-osbs/openshift4-cnf-tests:rhaos-4.6-rhel-8-containers-candidate-50685-20201117174118

-----------------------------------------------------------------------------------------------------------------------------------------
apiVersion: sriovnetwork.openshift.io/v1
Version: sriovnetwork.openshift.io/v1
kind: SriovNetworkNodePolicy
metadata:
  name: my-policy
  namespace: openshift-sriov-network-operator
spec:
  resourceName: sriovnic
  nodeSelector:
    node-role.kubernetes.io/worker-cnf: ""
  priority: 10
  numVfs: 5
  nicSelector:
    pfNames: ["ens1f0"]
  deviceType: "vfio-pci"
  isRdma: false

-----------------------------------------------------------------
dpdk Validate a DPDK workload running inside a pod 
  Should forward and receive packets
  /remote-source/app/functests/dpdk/dpdk.go:170
STEP: Parsing output from the DPDK application

• [SLOW TEST:57.549 seconds]
dpdk
/remote-source/app/functests/dpdk/dpdk.go:88
  Validate a DPDK workload running inside a pod
  /remote-source/app/functests/dpdk/dpdk.go:169
    Should forward and receive packets
    /remote-source/app/functests/dpdk/dpdk.go:170

Comment 13 errata-xmlrpc 2020-12-17 06:55:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.8 low-latency extras update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5187


Note You need to log in before you can comment on or make changes to this bug.