Bug 1889868 - [3.11] pkg/build/builder unit tests broken (TestDockerfilePath, TestDockerfileFromScratch, TestDockerBuildError, TestPushError, TestGetStrategyError)
Summary: [3.11] pkg/build/builder unit tests broken (TestDockerfilePath, TestDockerfil...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.11.z
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks: 1884421 1884422 1879445
TreeView+ depends on / blocked
 
Reported: 2020-10-20 18:26 UTC by Miciah Dashiel Butler Masters
Modified: 2020-11-12 10:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-12 10:08:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 25616 None closed [release-3.11] Bug 1889868: Clean up 3.11.z build tests 2020-11-16 16:13:16 UTC
Red Hat Product Errata RHBA-2020:4430 None None None 2020-11-12 10:08:55 UTC

Description Miciah Dashiel Butler Masters 2020-10-20 18:26:21 UTC
Description of problem:

The following unit tests consistently fail on the release-3.11 branch of openshift/origin:

FAIL: github.com/openshift/origin/pkg/build/builder TestDockerfilePath 10ms
FAIL: github.com/openshift/origin/pkg/build/builder TestDockerfileFromScratch 0s
FAIL: github.com/openshift/origin/pkg/build/builder TestDockerBuildError 0s
FAIL: github.com/openshift/origin/pkg/build/builder TestPushError 0s
FAIL: github.com/openshift/origin/pkg/build/builder TestGetStrategyError 0s

For example, see the following failing CI runs:

https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/25542/pull-ci-openshift-origin-release-3.11-unit/1318476427833643008
https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/24958/pull-ci-openshift-origin-release-3.11-unit/1318575610506776576
https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/25613/pull-ci-openshift-origin-release-3.11-unit/1318480791000322048


Version-Release number of selected component (if applicable):

3.11


How reproducible:

Consistently.


Steps to Reproduce:

1. Open an empty PR in openshift/origin (for example, see https://github.com/openshift/origin/pull/25613).


Actual results:

The ci/prow/unit CI job fails.


Expected results:

The ci/prow/unit CI job passes.


Additional info:

These failures were previously reported on 2020-04-14 in https://github.com/openshift/origin/issues/24874.  

These failures seem to affect all PRs to openshift/origin's release-3.11 branch, which costs developer time and CI resources and delays fixes to 3.11 (because fixes cannot merge until an issue gets escalated to the point that someone overrides the failing jobs).

Comment 1 Adam Kaplan 2020-10-21 21:48:02 UTC
3.11 CI is using a broken version of Docker. Filed https://bugzilla.redhat.com/show_bug.cgi?id=1890328. In the meantime affected tests are going to be skipped.

Comment 4 wewang 2020-10-23 08:51:27 UTC
Maybe need later job to check, since the pr is merged 13 hours ago

Comment 5 wewang 2020-10-26 03:34:01 UTC
Job is still 3 days ago

Comment 6 wewang 2020-10-26 06:57:28 UTC
Verified it, "Run test unit - container test"  is pass in job: https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/25616/pull-ci-openshift-origin-release-3.11-unit/1319322851123138560

Comment 9 errata-xmlrpc 2020-11-12 10:08:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 3.11.317 bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4430


Note You need to log in before you can comment on or make changes to this bug.