Bug 1889976 - [5.0] Ceph-Dashboard: Delete Host via dashboard UI is successful but host lists still shows the entry
Summary: [5.0] Ceph-Dashboard: Delete Host via dashboard UI is successful but host lis...
Keywords:
Status: CLOSED DUPLICATE of bug 1889985
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Dashboard
Version: 5.0
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: rc
: 5.0
Assignee: Ernesto Puerta
QA Contact: Preethi
Anjana Suparna Sriram
URL:
Whiteboard: cephadm
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-21 06:52 UTC by Preethi
Modified: 2020-10-27 16:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:10:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
Deleted entry seen (246.40 KB, image/png)
2020-10-21 06:52 UTC, Preethi
no flags Details

Description Preethi 2020-10-21 06:52:31 UTC
Created attachment 1723092 [details]
Deleted entry seen

Description of problem:Delete Host via dashboard UI is successful but host lists still shows the entry in ceph-dashboard 5.0


Version-Release number of selected component (if applicable):
[root@magna094 ubuntu]# ./cephadm version
Using recent ceph image registry-proxy.engineering.redhat.com/rh-osbs/rhceph:ceph-5.0-rhel-8-containers-candidate-96803-20201013192445
ceph version 16.0.0-6275.el8cp (d1e0606106224ac333f1c245150d7484cb626841) pacific (dev)


How reproducible:


Steps to Reproduce:
1. Install 5.0 cluster
2. login to Dashboard UI and click on hosts section
3. Perform delete Host i.e magna093
4. Observe the behaviour


Actual results:
Magna093 is deleted succesfuly, but host entry still shows in the host list whereas cli reports deleted and removed from the hosts list similarly we see notification in dashboard for removed host.


Attached error snippet:

Expected results: Deleted host entry should be removed and not seen anywhere


Additional info:

Comment 3 Juan Miguel Olmo 2020-10-27 16:10:09 UTC

*** This bug has been marked as a duplicate of bug 1889985 ***


Note You need to log in before you can comment on or make changes to this bug.