Bug 189 - MAKEDEV/dev/linuxconf package install failures
MAKEDEV/dev/linuxconf package install failures
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: MAKEDEV (Show other bugs)
5.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
: 848 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-24 13:57 EST by dschenck
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-13 16:56:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dschenck 1998-11-24 13:57:14 EST
IMO, the FTP install option is a correct choice for myself.
I *have* the necessary connection throughput (MediaOne
BroadBand), but am required to use PASV FTP due to the
local net architecture.  This latter point does not effect
the issue, but wanted you to be aware that I am aware of
it.

The three .rpm packages selected above will invariably fail
with an ambiguous 'execution of install script failed'.
The modal error dialog only needs to be 'okayed' and the
installation will continue with the next package happily.

There is obviously no post-intall boot capability with a
crippled /dev directory.  Past that, there are silent
failures in the other packages that need a proper directory
structure to complete successfully.

I suspect this will end up being attributed to the same
directory structure 'case sensitivity' issue that, I have
read and am soon to experience first-hand, plagues RedHat
5.2.

Thank you for your time.
David Schenck +++ dschenck@mn.mediaone.net
Comment 1 dschenck 1998-11-24 13:59:59 EST
The three .rpm packages are dev, linuxconf, MAKEDEV.
Comment 2 David Lawrence 1998-11-24 17:04:59 EST
We were unable to replicate this problem on two machines what we
attempted ftp installs to. Could possible be older versions of those
packages than the current shipping packages. We had similar troubles
with earlier versions of 5.2 beta copies and have hopefully eliminated
the problesm with the latest versions.
Comment 3 craig 1998-11-26 14:05:59 EST
I too have had this problem with one machine or two machines.  Its odd
I can make the dev MAKEDEV linuxconf failure happen every time on one
notebook I have no reason for it.  I thought it was originaly due to a
bad mirror or I re-mirrored and that didn't help either  tried the
cdrom and had the same results on this one machine.
Comment 4 Jeff Johnson 1999-01-17 11:38:59 EST
*** Bug 189 has been marked as a duplicate of this bug. ***

I have had a problem with my new Chembook 7400 laptop
(which is actually an Asus Grandio F7400.) During an ftp
install with redhat linux 5.2 I get three files that get
the "execution of script failed". Dev, makedev and
linuxconf rpms are the only ones that fail but they
consistently do. Since the dev rpm deals with devices, it
prevents me from doing a floppy install disk, as well as
installing lilo so the whole installation stays stuck.
Components of the 7400 can be found at
http://www.chembook.chemusa.com/chembook/7400/7400comp.html
further info about this laptop can be found at
http://www.asus.com/Products/Specs/Notebook/f7400-Spec.asp

I have also done a search of newsgroups and found a couple
of other instances of this problem (although I don't know
if the same files were the issue). Both machines were
different than mine though.




------- Additional Comments From sczjd@yahoo.com  01/16/99 03:51 -------
First file to get the above error during installation. It is possible
that the other two errors are in response to this one.

------- Additional Comments From sczjd@yahoo.com  01/16/99 03:53 -------
The dev rpm is the rpm that is the first to get the error message
during the installation.

------- Additional Comments From ayn2@cornell.edu  01/16/99 06:32 -------
This is a duplicate of #189 (which was closed as "WORKSFORME" and
should probably be reopened).
Comment 5 David Lawrence 1999-01-18 15:14:59 EST
We have observed this to mostly happen if ftp is given ample enough
time to time out and the connection is closed. For instance if between
the time you open the ftp connection in the beginning of the install
to the time the first package is tranferred exceeds say arount 10-15
minutes then the ftp server disconnects and the install code does not
try to reconnect properly. We are working to have this problem fix for
the next release.
Comment 6 Matt Wilson 1999-03-13 16:56:59 EST
FTP installs have been overhauled for the next release.
Comment 7 karsten 1999-04-14 14:05:59 EDT
FIXED, seems to mean fixed for RedHat 5.3 ... ?
As there are no suggestions for RedHat 5.2 yet, I'll try one.
At my failed installation(s), the dev-rpm can't be installed, because
rpm can't open /etc/group.
It can't, because the setup-rpm (containing passwd, group,etc.) isn't
installed.
So it seems to me, that as the connection timed out after formatting
the harddisks, the setup-rpm wasn't downloaded / installed.

So what propably could "rescue" the installation is:
(assuming you already have a working redhat-linux, you can steal all
the files from :)
1.preparing a disk with the setup-rpm, the rpm-binary, the contents of
/var/lib/rpm (as the rpm-database will be locked, and i know no way of
overriding that lock,nor do copies of the locked files work), and the
shell of your choice
(I had another harddisk with a complete installation, i could mount
during the install)
2. Do the normal installation. When the timeout after the formatting
of the harddisks occures, switch to the shell (Alt-F2)
3. mkdir /mymount ;mount the floppy or harddisk (I hope you can mount
floppys at this stage ...)
4. mv /mnt/var/lib/rpm /mnt/var/lib/rpm.ori
5. cp -R /mymount/rpm/ /mnt/var/lib/rpm/
6. rpm --root /mnt -i /mymount/setup*rpm --force #write the full name
7. mv /mnt/var/lib/rpm /mnt/var/lib/rpm.tmp#rm -rf doesnt work with
the rm on the install disk - delete it later
8. mv /mnt/var/lib/rpm.ori /mnt/var/lib/rpm
9. switch back to tty1 (Alt-F1) and finish the installation
10. Boot the system and fix the messed up rpm-database, with something
like rpm -U --force setup*rpm or rpm -i --force setup*rpm

I haven't tried an installation exactly like this, I installed the
setup and dev-rpms, as the installation of the dev-rpm failed
(Well, I had to find out why it failed first and only then fixed the
not-installed rpms)
by mounting a working linux partition and getting all needed files
from there or by ftping to a redhat mirror site during install.

Now, after the installation the system booted and everything seems
quite normal up to now (ca. 2 h after  installation)

Note You need to log in before you can comment on or make changes to this bug.