This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 189000 - parted rescue segfaults
parted rescue segfaults
Status: CLOSED DUPLICATE of bug 188998
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
5
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-14 11:16 EDT by Robert Story
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 11:27:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Story 2006-04-14 11:16:13 EDT
Description of problem:
Trying to recover from a problem shrinking a hfs+ partition (see Bug #18899), I
tried deleting the partition via parted, thinking that rescue might restore the
partition to the size that OS X sees. however, immediately after asking for the
start, parted segfaults.

Version-Release number of selected component (if applicable):
parted-1.6.25-8

How reproducible:
always

Steps to Reproduce:
1. delete (unused) partition X
2. try rescue, giving it the starting point of the partion
3.
  
Actual results:
parted segfaults

Expected results:
parted rescues the partition

Additional info:
Comment 1 Robert Story 2006-04-14 11:19:19 EDT
sorry, the reference to the previous shrink bug should be Bug #188998.
Comment 2 David Cantrell 2006-04-25 11:27:25 EDT
Even if parted wasn't segfaulting, you wouldn't be able to resize HFS+.  Parted
can only shrink HFS and HFS+ partitions, not increase them.

Closing as a dup of Bug #188998.

*** This bug has been marked as a duplicate of 188998 ***

Note You need to log in before you can comment on or make changes to this bug.