Bug 189023 - proftpd conflicts with vsftpd
Summary: proftpd conflicts with vsftpd
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: proftpd (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
: 189021 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-14 20:48 UTC by Ted
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.3.0-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-02 15:45:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ted 2006-04-14 20:48:48 UTC
Description of problem:
pirut cannot install proftpd.

How reproducible:
Reproducible easily.

Steps to Reproduce:
1.Run "pirut".
2.Select "Servers->FTP->proftpd"
3.Click "Apply"
  
Actual results:
Error resolving dependencies:
proftpd conflicts with vsftpd

Expected results:
Software installation succesful.

Additional info:
vsftpd is the "Servers->FTP" itself.
I posted this bug multiple times.

Comment 1 Ted 2006-04-14 20:52:25 UTC
189021 is my older version-may still have typographical error.

Comment 2 Jeremy Katz 2006-04-17 22:12:38 UTC
*** Bug 189021 has been marked as a duplicate of this bug. ***

Comment 3 Jeremy Katz 2006-04-17 22:19:00 UTC
This is a packaging bug.  Packages in Extras should not conflict with packages
from Core and should instead be able to be installed alongside Core packages.

Comment 4 Matthias Saou 2006-04-21 14:21:58 UTC
Some files used to conflict between vsftpd and proftpd, I think it was the pam.d
file but I couldd be wrong. This is no longer the case, so I've removed the
explicit conflicts it had against vsftpd, wu-ftpd and anonftp (which are long
gone now). I've tested and installing both works, although the use of having
more than one ftp server installed is something I fail to understand :-)
Expect 1.3.0 final with this fixed to appear really soon in devel, and shortly
after for FC-5.


Note You need to log in before you can comment on or make changes to this bug.